Bug 1259666 - fix ftbfs on aarch64 in condor
fix ftbfs on aarch64 in condor
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: condor (Show other bugs)
rawhide
aarch64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: matt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: ARM64/F-ExcludeArch-aarch64
  Show dependency treegraph
 
Reported: 2015-09-03 06:14 EDT by Marcin Juszkiewicz
Modified: 2015-09-23 00:08 EDT (History)
6 users (show)

See Also:
Fixed In Version: 8.3.6-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 00:08:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch + spec changeset (2.48 KB, application/mbox)
2015-09-03 06:14 EDT, Marcin Juszkiewicz
no flags Details
CMakeCache.txt (40.07 KB, text/plain)
2015-09-09 04:23 EDT, Marcin Juszkiewicz
no flags Details

  None (edit)
Description Marcin Juszkiewicz 2015-09-03 06:14:05 EDT
Created attachment 1069725 [details]
patch + spec changeset

Description of problem:

Condor defines uint64_t type but this is conflicting with definition in stdint.h and build fails.

Version-Release number of selected component (if applicable):

8.3.6-3

How reproducible:

always

Steps to Reproduce:
1. do build on aarch64 (use arm-koji)

Actual results:

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=3160851

In file included from /usr/lib/gcc/aarch64-redhat-linux/5.1.1/include/stdint.h:9:0,
                 from /usr/include/c++/5.1.1/cstdint:41,
                 from /usr/include/c++/5.1.1/bits/char_traits.h:380,
                 from /usr/include/c++/5.1.1/string:40,
                 from /builddir/build/BUILD/htcondor-8_3_6/src/condor_utils/condor_event.h:36,
                 from /builddir/build/BUILD/htcondor-8_3_6/src/condor_utils/read_user_log.h:45,
                 from /builddir/build/BUILD/htcondor-8_3_6/src/condor_userlog/condor_userlog_job_counter.cpp:30:
/usr/include/stdint.h:40:19: error: conflicting declaration 'typedef long int int64_t'
 typedef long int  int64_t;
                   ^

Expected results:

package builds

Additional info:

Fix is not perfect but solved problem.
Comment 1 Brian Bockelman 2015-09-08 23:17:18 EDT
Hi Marcin,

Thank you very much for the bug report!

To me, this appears to be a cmake issue - cmake was supposed to determine whether this typedef already existed (I suspect the typedef in condor is for old compilers for windows / solaris).

Is there any way to pull CMakeCache.txt from the failed build? 

Brian
Comment 2 Marcin Juszkiewicz 2015-09-09 01:22:24 EDT
Will do a build and attach it.
Comment 3 Marcin Juszkiewicz 2015-09-09 04:23:16 EDT
Created attachment 1071611 [details]
CMakeCache.txt
Comment 4 Brian Bockelman 2015-09-09 10:12:57 EDT
Ah - I see the issue:

CMake properly detects int64_t already detects.  *However*, this particular file doesn't include the config.h because the header read_user_log.h is meant to be part of the public API.

Probably this header needs to be generated separately by cmake.

Will file a ticket with upstream HTCondor.

For now, the proposed patch looks fine.
Comment 5 Peter Robinson 2015-09-14 11:52:09 EDT
> For now, the proposed patch looks fine.

Can we get it applied and pushed for F-23+ then?
Comment 6 Marcin Juszkiewicz 2015-09-17 11:23:14 EDT
pushed to rawhide
Comment 7 Fedora Update System 2015-09-17 14:38:18 EDT
condor-8.3.6-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16124
Comment 8 Fedora Update System 2015-09-17 17:29:17 EDT
condor-8.3.6-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update condor'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16124
Comment 9 Fedora Update System 2015-09-23 00:08:28 EDT
condor-8.3.6-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.