Bug 1259671 - [abrt] dnf: packages.py:76:parsePackages:TypeError: unhashable type: 'YumHistoryPackageState'
[abrt] dnf: packages.py:76:parsePackages:TypeError: unhashable type: 'YumHist...
Status: CLOSED DUPLICATE of bug 1245121
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:56f74f073c3c856759c8def3b6c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 06:27 EDT by Christian Stadelmann
Modified: 2015-09-07 07:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-07 07:58:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.58 KB, text/plain)
2015-09-03 06:27 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-09-03 06:27:53 EDT
Version-Release number of selected component:
dnf-1.1.1-1.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -OO /usr/bin/dnf history info plymouth-core-libs
executable:     /usr/bin/dnf
kernel:         4.2.0-1.fc23.x86_64
runlevel:       N 5
type:           Python3

Truncated backtrace:
packages.py:76:parsePackages:TypeError: unhashable type: 'YumHistoryPackageState'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 195, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 141, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1085, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/__init__.py", line 1217, in run
    ret = self.output.historyInfoCmd(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1535, in historyInfoCmd
    self._historyInfoCmd(tid, pats)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1673, in _historyInfoCmd
    self.historyInfoCmdPkgsAltered(old, pats)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1748, in historyInfoCmdPkgsAltered
    x, m, u = dnf.yum.packages.parsePackages([hpkg], pats)
  File "/usr/lib/python3.4/site-packages/dnf/yum/packages.py", line 76, in parsePackages
    exactmatch.update(pkgdict[command])
TypeError: unhashable type: 'YumHistoryPackageState'

Local variables in innermost frame:
command: 'plymouth-core-libs'
usercommands: ['plymouth-core-libs']
pkgdict: {'plymouth-core-libs': [<YumHistoryPackageState : plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64 (0x7f1ee0d1ea90)>], 'plymouth-core-libs.x86_64': [<YumHistoryPackageState : plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64 (0x7f1ee0d1ea90)>], 'plymouth-core-libs-0:0.8.9-10.2013.08.14.fc23.x86_64': [<YumHistoryPackageState : plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64 (0x7f1ee0d1ea90)>], 'plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64': [<YumHistoryPackageState : plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64 (0x7f1ee0d1ea90)>], '0:plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64': [<YumHistoryPackageState : plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64 (0x7f1ee0d1ea90)>], 'plymouth-core-libs-0.8.9': [<YumHistoryPackageState : plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64 (0x7f1ee0d1ea90)>], 'plymouth-core-libs-0.8.9-10.2013.08.14.fc23': [<YumHistoryPackageState : plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64 (0x7f1ee0d1ea90)>]}
pkgs: [<YumHistoryPackageState : plymouth-core-libs-0.8.9-10.2013.08.14.fc23.x86_64 (0x7f1ee0d1ea90)>]
unmatched: set()
matched: set()
casematch: 0
exactmatch: set()
Comment 1 Christian Stadelmann 2015-09-03 06:27:56 EDT
Created attachment 1069728 [details]
File: backtrace
Comment 2 Radek Holy 2015-09-07 07:58:04 EDT

*** This bug has been marked as a duplicate of bug 1245121 ***

Note You need to log in before you can comment on or make changes to this bug.