Bug 1259686 - Backport request from upstream 4.3 - ARM: tegra: jetson-tk1
Backport request from upstream 4.3 - ARM: tegra: jetson-tk1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
armhfp Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2015-09-03 07:10 EDT by Nicolas Chauvet (kwizart)
Modified: 2015-10-20 08:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 08:46:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2015-09-03 07:10:57 EDT
Description of problem: kernel-4.2 for f23 may requires additional fixes from 4.3 that are relevant for GA release armhfp images.

We can expect to support nouveau and gpu acceleration with 4.3 kernel and fedora 23 cycle. There is a requirement on a recent git uboot, but once this uboot in place, it will break with GA 4.2 kernel that miss the gpu node. This is needed in case of a fedora-23 re-installation of the jetson-tk1 device to avoid complex re-bootstrapping issue.


Version-Release number of selected component (if applicable):
kernel-4.2-1.fc23

How reproducible:
always

Steps to Reproduce:
1. boot jetson-tk1 with upstream git uboot (or backported support for gpu)
2. bootloader will automatically enable the gpu from uboot side but will fails to do so because of the missing gpu node in the device-tree.

Actual results:
The bootloader will fail to find the device-tree gpu node and will fail to boot

Expected results:
Bootloader should find the required gpu node and boot successfully.

Note that once booted, the nouveau kernel will fails to load the firmware since the path has changed between 4.2 and 4.3, but this is not critical, we can wait for 4.3 to have full support for the firmware side.


Additional info:

Please backport the following uptream commit (already in 4.3):

commit aefdc4b76db00cba71d6f984f90e4814bb2365a7
Author: Alexandre Courbot <acourbot@nvidia.com>
Date:   Wed Jul 1 18:13:47 2015 +0900

    ARM: tegra: jetson-tk1: Add GK20A GPU DT node
    
    Add the device-tree node for the GK20A GPU and leave it disabled.
    It is the responsibility of the bootloader to enable it if the
    VPR registers have been programmed such that the GPU can operate.
    
    Signed-off-by: Alexandre Courbot <acourbot@nvidia.com>
    Signed-off-by: Thierry Reding <treding@nvidia.com>
Comment 1 Peter Robinson 2015-09-03 07:19:20 EDT
It actually needs more patches than just that. It's on my todo list to review and add.

We already have the needed patches in u-boot in F-23
Comment 2 Nicolas Chauvet (kwizart) 2015-09-03 07:28:35 EDT
(In reply to Peter Robinson from comment #1)
> It actually needs more patches than just that. It's on my todo list to
> review and add.
Thx for working on this!

What's the aim for f23 GA ? have a fully accelerated nouveau stack on wayland/Xorg ? Or can we wait for f23+updates to settle for that ?
Comment 3 Nicolas Chauvet (kwizart) 2015-10-20 08:46:59 EDT
Ok this is not relevant anymore since with llvm-3.7 we will have gnome-shell support out-of-the-box with fedora armhfp 23 GA on jetson-tk1!

Note You need to log in before you can comment on or make changes to this bug.