This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 125969 - mkisofs freeze system when work with lot of files
mkisofs freeze system when work with lot of files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-14 13:06 EDT by Daniel
Modified: 2015-01-04 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 20:02:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel 2004-06-14 13:06:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I'm using mkisofs in a shell script, and it aways work fine in RedHat 9
, but now I did a upgrade to Fedora core 2 teste2 and the machine freeze
when I put a directory with lot of files. 

Version-Release number of selected component (if applicable):
mkisofs-2.01-0.a27.3

How reproducible:
Always

Steps to Reproduce:
1.mkdir /root/teste
2.cp /etc /root/teste
3.cp /etc /root/teste/samba
4.cp /etc /root/teste/samba/samba
5.cp /etc /root/teste/samba/samba/samba
6.cp /etc /root/teste/samba/samba/samba/samba

mkisofs -V Teste -J -R -hfs --netatalk --double -mac-name -o teste.iso   
 /root/teste



Actual Results:  Sistem freeze!

Additional info:
Comment 1 Harald Hoyer 2004-06-15 04:16:01 EDT
can you upgrade to the "real" Fedora Core 2 release?
Comment 2 Daniel 2004-06-15 16:10:28 EDT
How can I know witch version is "real"?
Comment 3 Daniel 2004-06-15 16:13:02 EDT
How can I know witch is the lest version of core 2? I'm downloading
test 3 now!

Comment 5 Daniel 2004-06-16 09:58:02 EDT
I'm using these one! I have other question, fedora core 2 have tree
versions, test1, test2, test3, how can I know in a installed system
which version I'm using if I lost the cd's?

Thank's Harald!
Comment 6 Harald Hoyer 2004-06-16 11:32:22 EDT
You can see the version with:
$ cat /etc/redhat-release
Fedora Core release 2 (Tettnang)
$ rpm -qf /etc/redhat-release
fedora-release-2-4

you can try to update your system with yum.
read http://www.fedorafaq.org/#installsoftware

# rpm -Uvh \
http://download.fedora.redhat.com/pub/fedora/linux/core/2/i386/os/Fedora/RPMS/fedora-release-2-4.i386.rpm
# cd /etc
# wget http://www.fedorafaq.org/samples/yum.conf
# yum upgrade
Comment 7 Daniel 2004-06-16 12:02:14 EDT
My release:
Fedora Core release 2 (Tettnang)
rpm -qf /etc/redhat-release
fedora-release-2-4

Now I know that I'm using the right version, so the problem still
persist. What can I do?

my version of mkisofs:
mkisofs-2.01-0.a27.4
the original was mkisofs-2.01-0.a27.3


 
Comment 8 Harald Hoyer 2004-06-16 12:19:57 EDT
hmm, ok, you are in good shape with your packages.
how exactly does your system freeze? No response? Total crash? Do you
have 3rd party kernel modules?
Comment 9 Daniel 2004-06-16 15:00:04 EDT
In fact it freeze totaly, the display looks like a printscreem, without
a "Kernel Panic" just freeze and in /var/log/messages dont apear nothing
, just a big space of time like 12:30:22 12:37:11.
I change my OS to RedHat 9 and it work perfectly!

Sorry about my english.
Thanks
Comment 10 Daniel 2004-06-17 14:06:43 EDT
Hello Harald, I'm still waiting for some answer, did you reproduce
the bug?
Comment 11 Harald Hoyer 2004-06-18 04:00:07 EDT
sorry, I tried to reproduce it, but I could really not... My system
was busy, ok, but not freezing.
Maybe it is some driver problem, that shows up under heavy load?
Mkisofs doesn't do any magic, that could freeze your system.
I'll reassign this bug to kernel, because I cannot really hint you
where to look further.
I hope the kernel guys can pin down your problem. Sorry!
Comment 12 Arjan van de Ven 2004-06-18 04:02:55 EDT
we fixed a similar symptom by a bugfix in the 4g/4g patch recently,
the 435 erratum kernel has this fix. Does it still reproduce with that
kernel ?
Comment 13 Daniel 2004-06-18 14:17:21 EDT
Yes my frend, Fedora Core 2 have a big bug in default instalation with
mkisofs in all kind of hardware, I did test myself with 4 diferent
machines!!!
When you upgrade kernel to 2.6.6 these bug are fixed, so please alert
your peaple is a big bug with sure!

Note You need to log in before you can comment on or make changes to this bug.