Bug 1259692 - netstat to print also ESTABLISHED connections
Summary: netstat to print also ESTABLISHED connections
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Debug
Version: 6.1.1
Hardware: All
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact:
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-03 11:24 UTC by Pavel Moravec
Modified: 2019-09-26 18:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:55:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11677 None None None 2016-04-22 16:53:18 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Pavel Moravec 2015-09-03 11:24:17 UTC
Description of problem:
foreman-debug generates netstat file as an output of "netstat -tulpn" command. -l means only listening sockets are displayed. While it is often important to see also _established_ connections, i.e. celery connected to CDN:443 during repo sync, goferd on a content host to 5647, dispatch router on capsule to 5646, etc. If some such connection is missing, it is a symptom of some problem - but netstat in foreman-debug does not provide that info.

Please provide "netstat -putna" output rather (-l --> -a, print _all_ sockets).


Version-Release number of selected component (if applicable):
foreman-debug-1.7.2.34-1.el7sat.noarch


How reproducible:
100%


Steps to Reproduce:
1. foreman-debug
2. (in extracted tarball):  grep ESTAB netstat


Actual results:
no established TCP connection


Expected results:
many established connections, like:

tcp        0      0 1.2.3.4:40912      1.2.3.4:5671       ESTABLISHED 25428/qdrouterd     


Additional info:

Comment 2 Bryan Kearney 2015-09-04 14:04:19 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11677 has been closed
-------------
Pavel Moravec
Applied in changeset commit:ee3275af331a74e8aae6c3654c914ebd7d4267c7.

Comment 3 Tazim Kolhar 2015-11-19 09:39:27 UTC
VERIFIED:
# rpm -qa | grep foreman
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-proxy-1.0-1.noarch
foreman-release-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-vmware-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-debug-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511161350git860ef06.el7.noarch
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511161350git860ef06.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-proxy-1.11.0-0.develop.201511161424gitf24be74.el7.noarch
foreman-compute-1.11.0-0.develop.201511161350git860ef06.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-client-1.0-1.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201511111650gitdda13df.el7.noarch
foreman-gce-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-release-scl-1-1.el7.x86_64
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch

steps:
30607/ntpd          
udp6       0      0 ::1:123                 :::*                                30607/ntpd          
udp6       0      0 :::123                  :::*                                30607/ntpd          
udp6       0      0 :::45455                :::*                                15518/dhcpd         
udp6       0      0 ::1:33704               ::1:33704               ESTABLISHED 4220/postgres: fore

Comment 6 errata-xmlrpc 2016-07-27 08:55:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.