Bug 1259698 - Proxy cannot be configured with remote DHCP server
Proxy cannot be configured with remote DHCP server
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: 6.1.3
: --
Assigned To: Lukas Zapletal
Corey Welton
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1152050
  Show dependency treegraph
 
Reported: 2015-09-03 07:51 EDT by Lukas Zapletal
Modified: 2017-02-23 14:46 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 14:20:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11676 None None None 2016-04-22 12:00 EDT

  None (edit)
Description Lukas Zapletal 2015-09-03 07:51:50 EDT
This small patch is required for external service support, as requested in https://bugzilla.redhat.com/show_bug.cgi?id=1152050
Comment 2 Bryan Kearney 2015-09-03 08:04:21 EDT
Upstream bug assigned to lzap@redhat.com
Comment 3 Bryan Kearney 2015-09-03 08:04:22 EDT
Upstream bug component is Capsule
Comment 5 Lukas Zapletal 2015-09-11 04:42:32 EDT
WORKAROUND: Edit /usr/share/foreman-proxy/modules/dhcp/dhcp_api.rb and replace the IP address on the line 17 to match your DHCP external service:

    @server = Proxy::DHCP::ISC.new(:name => "127.0.0.1",

Then restart foreman-proxy service.
Comment 6 Bryan Kearney 2015-09-11 08:04:51 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/11676 has been closed
Comment 9 Og Maciel 2015-10-09 10:41:01 EDT
VERIFIED with testing performed by Lukas Zapletal.
Comment 11 errata-xmlrpc 2015-10-15 14:20:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911

Note You need to log in before you can comment on or make changes to this bug.