Bug 1259702 - g++: error: unrecognized command line option ‘-posix’
g++: error: unrecognized command line option ‘-posix’
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
aarch64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARM64/F-ExcludeArch-aarch64
  Show dependency treegraph
 
Reported: 2015-09-03 08:00 EDT by Marcin Juszkiewicz
Modified: 2015-09-03 08:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 08:42:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Juszkiewicz 2015-09-03 08:00:42 EDT
Description of problem:

pdfedit fails to build from source on aarch64 because it is using -posix switch. It works fine on primary architectures but on aarch64 g++ does not know that switch:

13:53 hrw@pinkiepie-rawhide:puchatek-del$ g++ hello.cc -posix
g++: error: unrecognized command line option ‘-posix’

13:55 hrw@puchatek:del$ g++ -posix hello.cc
13:58 hrw@puchatek:del$ 

pinkiepie is aarch64, puchatek is x86-64. Both have same version of g++ installed:

13:58 hrw@puchatek:del$ g++ --version
g++ (GCC) 5.1.1 20150618 (Red Hat 5.1.1-4)
13:55 hrw@pinkiepie-rawhide:puchatek-del$ g++ --version
g++ (GCC) 5.1.1 20150618 (Red Hat 5.1.1-4)


Version-Release number of selected component (if applicable):

5.1.1-4

How reproducible:

always

Steps to Reproduce:
1. g++ -posix hello.cc

Actual results:

13:53 hrw@pinkiepie-rawhide:puchatek-del$ g++ hello.cc -posix
g++: error: unrecognized command line option ‘-posix’

Expected results:

source compiled

Additional info:
Comment 1 Jakub Jelinek 2015-09-03 08:22:15 EDT
Just fix up pdfedit not to do it, use portable -D_POSIX_SOURCE instead?
These compatibility options really shouldn't be added to new ports.
Comment 2 Marcin Juszkiewicz 2015-09-03 08:42:23 EDT
Thanks Jakub.

Will patch.

Note You need to log in before you can comment on or make changes to this bug.