Bug 1259704 - publican fails to build docs with bogus error about duplicate IDs
publican fails to build docs with bogus error about duplicate IDs
Status: CLOSED DUPLICATE of bug 1199396
Product: Fedora
Classification: Fedora
Component: publican (Show other bugs)
22
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ruediger Landmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 08:04 EDT by Daniel Berrange
Modified: 2015-09-03 13:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 13:35:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2015-09-03 08:04:21 EDT
Description of problem:

Any doc which includes a <preface> section results in an error about duplicate IDs as follows:

$ make
publican build --langs=en-US --formats=html --common_content=/usr/share/publican/Common_Content
Setting up en-US
	Processing file tmp/en-US/xml/Common_Content/Conventions.xml -> tmp/en-US/xml/Common_Content/Conventions.xml
	Processing file tmp/en-US/xml/Common_Content/Feedback.xml -> tmp/en-US/xml/Common_Content/Feedback.xml
	Processing file tmp/en-US/xml/Common_Content/Legal_Notice.xml -> tmp/en-US/xml/Common_Content/Legal_Notice.xml
	Processing file tmp/en-US/xml/Common_Content/Program_Listing.xml -> tmp/en-US/xml/Common_Content/Program_Listing.xml
	Processing file tmp/en-US/xml/Common_Content/Revision_History.xml -> tmp/en-US/xml/Common_Content/Revision_History.xml
	Processing file tmp/en-US/xml_tmp/Application_Development_Guide.xml -> tmp/en-US/xml/Application_Development_Guide.xml
	Processing file tmp/en-US/xml_tmp/Architecture.xml -> tmp/en-US/xml/Architecture.xml
	Processing file tmp/en-US/xml_tmp/Author_Group.xml -> tmp/en-US/xml/Author_Group.xml
	Processing file tmp/en-US/xml_tmp/Book_Info.xml -> tmp/en-US/xml/Book_Info.xml
	Processing file tmp/en-US/xml_tmp/Connections.xml -> tmp/en-US/xml/Connections.xml
	Processing file tmp/en-US/xml_tmp/Guest_Domains.xml -> tmp/en-US/xml/Guest_Domains.xml
	Processing file tmp/en-US/xml_tmp/HVSupport.xml -> tmp/en-US/xml/HVSupport.xml
	Processing file tmp/en-US/xml_tmp/Host_Devices.xml -> tmp/en-US/xml/Host_Devices.xml
	Processing file tmp/en-US/xml_tmp/Introduction.xml -> tmp/en-US/xml/Introduction.xml
	Processing file tmp/en-US/xml_tmp/Language_Bindings.xml -> tmp/en-US/xml/Language_Bindings.xml
	Processing file tmp/en-US/xml_tmp/Network_Interfaces.xml -> tmp/en-US/xml/Network_Interfaces.xml
	Processing file tmp/en-US/xml_tmp/Preface.xml -> tmp/en-US/xml/Preface.xml
	Processing file tmp/en-US/xml_tmp/Revision_History.xml -> tmp/en-US/xml/Revision_History.xml
	Processing file tmp/en-US/xml_tmp/Storage_Pools.xml -> tmp/en-US/xml/Storage_Pools.xml
	Processing file tmp/en-US/xml_tmp/Virtual_Networks.xml -> tmp/en-US/xml/Virtual_Networks.xml
Beginning work on en-US
FATAL ERROR: validity:513 in Application_Development_Guide.xml on line 8: ID Application_Development_Guide-Preface already defined
 at /usr/bin/publican line 1046.

The source definitely does not have a duplicate ID for this.


I even see this error if I try to re-build the publican source RPM - its own unit test suite fails with errors


t/410.Translate.t ............. ok
# 
# Testing blib/script/publican
FATAL ERROR: validity:513 in foo2.xml on line 8: ID pref-Documentation-foo2-Preface already defined
 at /mnt/1c5321f5-14d6-40a2-8ca1-dd61524c9576/berrange/src/fedora/publican/Publican-v4.1.3/blib/script/publican line 1046.

#   Failed test 'publish a book'
#   at t/900.publican.t line 70.
#          got: '512'
#     expected: '0'
/mnt/1c5321f5-14d6-40a2-8ca1-dd61524c9576/berrange/src/fedora/publican/Publican-v4.1.3/blib/script/publican syntax OK
# Looks like you failed 1 test of 19.



Version-Release number of selected component (if applicable):
publican-4.1.3-3.fc22.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try to build a doc with a <preface> section
2.
3.

Actual results:
FATAL ERROR: validity:513 in Application_Development_Guide.xml on line 8: ID Application_Development_Guide-Preface already defined

Expected results:
No error

Additional info:
Comment 1 Pete Travis 2015-09-03 13:35:26 EDT
This is due to a libxml2 validation bug.  Publican and other tools relying on libxm2 are in sad shape until it is fixed.

*** This bug has been marked as a duplicate of bug 1199396 ***

Note You need to log in before you can comment on or make changes to this bug.