Bug 1259711 - totem - unable to add local/web video
totem - unable to add local/web video
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: totem (Show other bugs)
7.2
Unspecified Linux
unspecified Severity high
: beta
: ---
Assigned To: Bastien Nocera
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 08:14 EDT by Ladislav Kolacek
Modified: 2015-11-19 03:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:43:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ladislav Kolacek 2015-09-03 08:14:59 EDT
Description of problem:
Test cases failure: 
https://tcms.engineering.redhat.com/case/196181/?from_plan=18707
https://tcms.engineering.redhat.com/case/490727/?from_plan=18707

Version-Release number of selected component (if applicable):
kernel-3.10.0-313.el7.ppc64
totem-3.14.3-2.el7.ppc64

How reproducible:
100%

Steps to Reproduce:
1. Have a local video file downloaded and prepared
2. In totem click the plus button in the upper left corner and select "Add local/web video..."
3. Select the prepared local video (or input address of the file you would like to open) 

Actual results:
Video wasn't added.

Expected results:
Totem will add the video file to "Videos" section successfully. Then, after clicking on its icon, the video can be played.

Additional info:
Problem appears on architectures: x86_64, ppc64, ppc64le, aarch64
Comment 1 Bastien Nocera 2015-09-03 09:52:48 EDT
This is due to bookmarks plugin being missing. See bug 1184200
Comment 2 Bastien Nocera 2015-09-03 12:03:53 EDT
That should be fixed in grilo-plugins-0.2.14-6.el7, could you please check?
Comment 3 Ladislav Kolacek 2015-09-04 05:24:56 EDT
Hello, on x86_64 everything works fine. I tested also secondary arch (ppc64, ppc64le) with same version of packages:

gom-0.2.1-2.el7
grilo-plugins-0.2.14-6.el7

and after update on this version totem starts segfaulting.

When I tried to get backtrace by gdb ... application works fine just like x86_64. Any idea how to get backtrace of this problem?
Comment 4 Bastien Nocera 2015-09-04 10:09:39 EDT
ABRT should allow you to capture a coredump and create a post-mortem backtrace. Does it only crash on ppc64?
Comment 6 Bastien Nocera 2015-09-15 05:35:01 EDT
The crasher is bug 1261939. As it works on x86-64, consider that verified.
Comment 11 errata-xmlrpc 2015-11-19 03:43:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2227.html

Note You need to log in before you can comment on or make changes to this bug.