Bug 1259767 - [GSS](6.4.z) "OutOfMemoryError: PermGen or Unable to Create new native thread " of a given server affects the admin console operation
[GSS](6.4.z) "OutOfMemoryError: PermGen or Unable to Create new native thread...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console, Domain Management (Show other bugs)
6.4.2
x86_64 Linux
urgent Severity high
: CR1
: EAP 6.4.13
Assigned To: jboss-set
Pavel Jelinek
:
Depends On:
Blocks: 1399986 1406567 eap6413-payload
  Show dependency treegraph
 
Reported: 2015-09-03 09:50 EDT by Vítor Corrêa
Modified: 2017-09-06 09:59 EDT (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBEAP-6252 Major Verified [GSS](7.1.0) loose of domain controller manageabilty after an OOM 2018-05-04 15:36 EDT
JBoss Issue Tracker JBEAP-6414 Major Verified [GSS](7.0.z) loose of domain controller manageabilty after an OOM 2018-05-04 15:36 EDT
JBoss Issue Tracker JBEAP-7631 Major Verified [7.1.0] Domain server 'kill' and 'destroy' operations need to ensure the server is dead 2018-05-04 15:36 EDT
JBoss Issue Tracker JBEAP-7632 Major Verified [GSS](7.0.z) Domain server 'kill' and 'destroy' operations need to ensure the server is dead 2018-05-04 15:36 EDT
Red Hat Knowledge Base (Solution) 877883 None None None 2016-09-28 15:38 EDT

  None (edit)
Description Vítor Corrêa 2015-09-03 09:50:26 EDT
Description of problem:

In a domain mode setup, when a server gets a "java.lang.OutOfMemoryError: PermGen space or Unable to create new native thread", it breaks the Management Interface. Sometimes the servers aren't listed or the servers just goes away.

Seems that the domain controller is waiting for an update of the host controller, but it will never finish since the JVM became irresponsible. Notice: The OOME should happens on deploy or if a server throws any OOM.

The environment went back to normal after we restart the host controller that contains the server which failed.

Version-Release number of selected component (if applicable):

6.4.2


How reproducible:

Easy to reproduce, but requires patience...

Steps to Reproduce:

JVM:

vcorrea$ java -version
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

EAP 6.4.2 and 6.4.3;

* Configure an EAP environment with 1 Domain Controller, 2 Host Controllers with 1 server each;
* Set a small size for the PermGen space (in our test was used 100mb);
* Pick a host controller and deploys as many application as you can until you have the "java.lang.OutOfMemoryError: PermGen space" during the deploy action;

Actual results:

* Once you have the OOME, go to the management console. You should notice some misbehavior with it, such as servers not being listed, or the metrics aren't being updated anymore;
* After restarting the host controller, everything should be back working again.

Expected results:

It should not impact the management console. The deployment action should recover from the error or kill the server automatically.
Comment 20 Jiří Bílek 2017-01-16 08:23:55 EST
Verified with EAP 6.4.13.CP.CR2
Comment 21 Petr Penicka 2017-02-03 11:47:49 EST
Released with EAP 6.4.13 on Feb 02 2017.
Comment 22 Petr Penicka 2017-02-03 11:47:55 EST
Released with EAP 6.4.13 on Feb 02 2017.

Note You need to log in before you can comment on or make changes to this bug.