This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1259768 - The RHSM addon should report background processing is ongoing and prevent early exit from Initial Setup until done
The RHSM addon should report background processing is ongoing and prevent ear...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Kevin Howell
John Sefler
: StringChange, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 09:55 EDT by Martin Kolman
Modified: 2017-08-01 15:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 15:18:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Message "System is registering to owner environment" is seen on spoke , while registration process is still in progress (143.95 KB, image/png)
2017-04-17 05:46 EDT, Shwetha Kallesh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Github candlepin/subscription-manager/pull/1495 None None None 2016-09-20 11:48 EDT

  None (edit)
Description Martin Kolman 2015-09-03 09:55:32 EDT
Description of problem:
The Subscription Manager addon for Initial Setup does not indicate that the addon is doing important work in the background (registration & attach) that should not be interrupted and allows the user to exit the Initial Setup hub vie the "FINISH CONFIGURATION" button even when the background processing is still ongoing. 

Version-Release number of selected component (if applicable):
subscription-manager-initial-setup-addon.x86_64 0:1.15.9-7.el7

How reproducible:
always

Steps to Reproduce:
1. enter the RHSM addon in IS
2. enter credentials and click the "Register button"
3. a rpogress bar shows up on the screen
4. click the "Done" button in the upper left to return to the hub
(the same steps are valid even for attach phase)

Actual results:
The subscription manager status message on the hub still reads "System is not registered RHSM", the spoke is marked as completed (no yellow warning sign is displayed) and the "FINISH CONFIGURATION" button can be clicked.

Expected results:
The subscription manager status message indicates background processing is going on (something like "Registering system to RHSM" or "Attaching subscription"), spoke is not marked as completed (yellow warning sign is displayed) and the "FINISH CONFIGURATION" button can't be clicked (as long as at least one spoke is not complete, the "FINISH CONFIGURATION" button can't be clicked.

Additional info:
Spoke status message can be set using the "status" spoke property and the "completed" property is used to mark spoke completeness.
Comment 2 Adrian Likins 2015-09-08 13:32:35 EDT
Hmm, current code will show 'completed' once registration finishes. But
the spoke is also not mandatory, so not sure of the implications.
Comment 3 John Sefler 2015-09-24 16:56:08 EDT
deferring for consideration in rhel-7.3.0 due to schedule and severity
Comment 6 Shwetha Kallesh 2017-04-17 05:46 EDT
Created attachment 1272018 [details]
Message "System is registering to owner environment" is seen on spoke , while registration process is still in progress

[root@dhcp35-160 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.7-1.el7
python-rhsm: 1.19.4-1.el7
Comment 7 errata-xmlrpc 2017-08-01 15:18:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083

Note You need to log in before you can comment on or make changes to this bug.