Bug 1259801 - Network spoke should always show up in Initial Setup GUI
Network spoke should always show up in Initial Setup GUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Martin Kolman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 10:32 EDT by Martin Kolman
Modified: 2015-11-19 05:04 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.43-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 05:04:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kolman 2015-09-03 10:32:52 EDT
Description of problem:
Now that the Subscription Manager addon is always present in Initial Setup GUI the Network spoke should be be also always present as the Subscription Manager addon needs network connectivity to function.

Without the network spoke the users might not be able to register due to no connectivity any by not having any way to enable it.

Possible scenarios where this might happen:
* DVD installations don't need network connectivity so network is not enabled by default
* network environment changes after the installation has been finished but before Initial Setup has been run
- this also applies to stuff like "OEM installs" where one party installs the system in their environment but another party is expected to finish the configuration via Initial Setup in their own environment

How reproducible:
always

Steps to Reproduce:
1. install RHEL 7.2 from DVD
2. do not enable networking during the installation
3. reboot

Actual results:
Initial Setup shows up, including the Subscription Manager addon, but without the Network Spoke. As networking is not enabled and Network spoke is not present it is not possible to successfully register.

Expected results:
Network spoke is present in Initial setup and can be used to enable networking.
Comment 4 errata-xmlrpc 2015-11-19 05:04:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2284.html

Note You need to log in before you can comment on or make changes to this bug.