Bug 1259805 - keyboard shortcut Switch to Next Screen stopped working in RHEL 7.2
keyboard shortcut Switch to Next Screen stopped working in RHEL 7.2
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-workspace (Show other bugs)
7.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 10:36 EDT by Jeff Bastian
Modified: 2015-09-09 10:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 09:52:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2015-09-03 10:36:22 EDT
Description of problem:
I have a keyboard shortcut configured for "Switch to Next Screen" in KDE; this toggles focus between my two monitors. This was working fine in RHEL 7.1, but it broke when I updated to RHEL 7.2 Beta.

(I also have Switch to Window Above/Below/Left/Right shortcuts and these five shortcuts make kwin feel like a tiling window manager, e.g., i3 or xmonad.)


Version-Release number of selected component (if applicable):
kde-workspace-4.11.19-6.el7.x86_64
kdelibs-4.14.8-4.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. go to KDE System Settings -> Shortcuts and Gestures -> Global Keyboard
   Shortcuts -> KWin
2. set a shortcut for Switch to Next Screen
3. Apply
4. use the new shortcut

Actual results:
nothing

Expected results:
focus toggles to other screen

Additional info:
shortcuts for Switch to Screen 0, Screen 1, etc. also fail
Comment 2 Jan Grulich 2015-09-08 10:15:09 EDT
Works for me on a freshly installed RHEL 7.2 beta. I tried to configure all shortcuts you mentioned and it worked pretty well.
Comment 3 Jeff Bastian 2015-09-08 13:26:58 EDT
I created a test user account with a clean home directory and tried again and I still see the same problem.  Maybe it's an issue with my system since I started with RHEL 7.0 Alpha yum updated all the way through to 7.2 Beta...  I'll see if I can do a fresh installation on a system with two monitors.
Comment 4 Jan Grulich 2015-09-08 15:53:25 EDT
I haven't tried to use multiple monitors, I was trying just to switch between virtual desktops and switching to window below / above. I'll try to test switching between screens tomorrow.
Comment 5 Jeff Bastian 2015-09-08 16:42:26 EDT
Ahh, yes, the other keys all work fine.  It's only switching focus from one screen (monitor) to another that broke.

It might be possible to test this with a virtual machine:
  https://access.redhat.com/discussions/1363063
Comment 6 Jan Grulich 2015-09-09 04:05:48 EDT
I managed to make it work, you just need to go to System settings → Window behavior → Window Behavior (on the left side) → Check "Separate screen focus". Could you please confirm that this works also for you?
Comment 7 Jeff Bastian 2015-09-09 09:52:39 EDT
That worked!  Thank you!

I didn't need to do this in RHEL 7.1, so I wonder what changed?  I'm sorry for not figuring this out myself.
Comment 8 Jan Grulich 2015-09-09 10:06:37 EDT
We did rebase of kde-workspace so this is probably a new kwin feature.

Note You need to log in before you can comment on or make changes to this bug.