Bug 1259816 - Deprecated stanza in unit file
Summary: Deprecated stanza in unit file
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: watchdog
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Josef Ridky
QA Contact: Martin Kyral
URL:
Whiteboard:
Keywords: EasyFix, Patch
: 1393317 (view as bug list)
Depends On:
Blocks: 1289025 1305230 1465906
TreeView+ depends on / blocked
 
Reported: 2015-09-03 14:47 UTC by Lukáš Nykrýn
Modified: 2018-10-30 11:24 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-10-30 11:23:52 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3220 None None None 2018-10-30 11:24 UTC

Description Lukáš Nykrýn 2015-09-03 14:47:45 UTC
watchdog-5.13-11.el7.x86_64

[/usr/lib/systemd/system/watchdog-ping.service:9] Unknown lvalue 'ControlGroup' in section 'Service'
[/usr/lib/systemd/system/watchdog.service:9] Unknown lvalue 'ControlGroup' in section 'Service'

This value was removed in systemd 204, long before rhel 7.0.

Comment 5 Josef Ridky 2018-06-20 09:35:38 UTC
*** Bug 1393317 has been marked as a duplicate of this bug. ***

Comment 6 Martin Kyral 2018-08-27 08:58:22 UTC
Bugfix verified. The deprecated stanza is no longer present in the unit file:

# cat /usr/lib/systemd/system/watchdog.service
[Unit]
Description=watchdog daemon
Wants=ipmi.service
After=ipmi.service
# man systemd.special
# auto added After=basic.target

[Service]
Type=forking
ExecStart=/usr/sbin/watchdog

[Install]
WantedBy=multi-user.target
#

Comment 8 errata-xmlrpc 2018-10-30 11:23:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3220


Note You need to log in before you can comment on or make changes to this bug.