Bug 1259820 - package redhat-release-server-7.2 on ppc64le is providing the wrong product certificate
package redhat-release-server-7.2 on ppc64le is providing the wrong product c...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: redhat-release (Show other bugs)
7.2
ppc64le Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Jan Blazek
Release Test Team
Lenka Spackova
:
Depends On:
Blocks: 1246125
  Show dependency treegraph
 
Reported: 2015-09-03 10:54 EDT by John Sefler
Modified: 2015-11-19 02:54 EST (History)
3 users (show)

See Also:
Fixed In Version: redhat-release-server-7.2-6.el7
Doc Type: Known Issue
Doc Text:
Incorrect certificate file for Red Hat Enterprise Linux Server for Power The cryptographic (public key) certificate file provided by Red Hat Enterprise Linux Server for Power, little endian 7.2 Beta contains an incorrect product identification tag. As a consequence, systems are unable to access the Beta content available online. To work around this problem, copy the updated certificate file onto the Red Hat Enterprise Linux Server for Power, little endian 7.2 Beta system following successful installation, but prior to registering the system with Red Hat Subscription Manager. Detailed instructions and the correct certificate file are available at https://access.redhat.com/articles/1603533
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:54:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL 7.2 Beta Product Cert for ppc64le (2.15 KB, text/x-vhdl)
2015-09-03 11:39 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2015-09-03 10:54:03 EDT
Description of problem:
As a continuation of Bug 1245052, the redhat-release-server-7.2 needs to be re-built to provide the correct product cert 

Version-Release number of selected component (if applicable):
[root@ibm-p8-kvm-04-guest-01 ~]# rpm -q redhat-release-server
redhat-release-server-7.2-3.el7.ppc64le


How reproducible:


Steps to Reproduce:
[root@ibm-p8-kvm-04-guest-01 ~]# rpm -ql redhat-release-server | grep 279.pem
/etc/pki/product-default/279.pem

[root@ibm-p8-kvm-04-guest-01 ~]# rct cat-cert /etc/pki/product-default/279.pem
+-------------------------------------------+
	Product Certificate
+-------------------------------------------+

Certificate:
	Path: /etc/pki/product-default/279.pem
	Version: 1.0
	Serial: 12750047592154746497
	Start Date: 2015-07-20 08:27:32+00:00
	End Date: 2035-07-15 08:27:32+00:00

Subject:
	CN: Red Hat Product ID [482e9750-cfb1-44dd-9931-6b2df2a03e38]

Issuer:
	C: US
	CN: Red Hat Entitlement Product Authority
	O: Red Hat, Inc.
	OU: Red Hat Network
	ST: North Carolina
	emailAddress: ca-support@redhat.com

Product:
	ID: 279
	Name: Red Hat Enterprise Linux for Power, little endian
	Version: 7.2 Beta
	Arch: ppc64le
	Tags: rhel-7,rhel-7-server      <======= NOTICE THIS
	Brand Type: 
	Brand Name: 


Actual results:
 Tags: rhel-7,rhel-7-server

Expected results:
 Tags: rhel-7,rhel-7-ibm-power-le

Additional info:

For the RHEL72 Beta builds, this is the product cert that should have been used: http://git.app.eng.bos.redhat.com/git/rcm/rcm-metadata.git/tree/product_ids/rhel-7.2-beta/Server-Server-ppc64le-95751135b49a-279-ext.txt

For the RHEL72 GA build, I DO NOT YET SEE THE CORRECT 279 PRODUCT CERT HERE http://git.app.eng.bos.redhat.com/git/rcm/rcm-metadata.git/tree/product_ids/rhel-7.2    THIS NEEDSINFO from dgregor or anthomas
Comment 2 John Sefler 2015-09-03 11:39:37 EDT
Created attachment 1069932 [details]
RHEL 7.2 Beta Product Cert for ppc64le

As a workaround for an already installed RHEL7.2 Beta system on ppc64le, I have attached the corrected product certificate.

Simply detach it and place it in the /etc/pki/product/ directory.  This will take precedence over the bad 279.pem file located in /etc/pki/product-default/ directory.

To verify it has been installed correctly...

[root@jsefler-7 ~]# rct cat-cert /etc/pki/product/279.pem | grep Tags
	Tags: rhel-7,rhel-7-ibm-power-le


              ^^^^^^^^^^^^^^^^^^^^^^^^^^
Those are the expected tags.
Comment 9 errata-xmlrpc 2015-11-19 02:54:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2107.html

Note You need to log in before you can comment on or make changes to this bug.