Bug 1259859 - Deleting a stack that is updating will cause the stack to be undeletable
Deleting a stack that is updating will cause the stack to be undeletable
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity medium
: async
: 6.0 (Juno)
Assigned To: Zane Bitter
Amit Ugol
: Triaged, ZStream
: 1265736 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 12:26 EDT by David Hill
Modified: 2016-04-26 22:36 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-heat-2014.2.3-8.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 08:30:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1384750 None None None Never

  None (edit)
Description David Hill 2015-09-03 12:26:21 EDT
Description of problem:
Trying to delete a stack that has been in an updating state for some time will make that stack undeletable

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a stack
2. Update the stack
3. While the stack is updating, try to delete it

Actual results:
Stack will be stuck in "delete_in_progress"

Expected results:
Stack should be deleted

Additional info:
Would it be possible to backport this commit to RHOS 6.0 :https://git.openstack.org/cgit/openstack/heat/commit/?id=e44629dab01057c65a14218f5d3ae19d5cdcf9e0
Comment 3 Zane Bitter 2015-09-03 13:14:05 EDT
That patch looks relatively simple to backport.
Comment 4 Zane Bitter 2015-09-23 20:53:32 EDT
Upstream backport: https://review.openstack.org/#/c/227065/
Comment 5 Zane Bitter 2015-09-23 20:54:51 EDT
*** Bug 1265736 has been marked as a duplicate of this bug. ***
Comment 13 errata-xmlrpc 2015-10-15 08:30:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1900.html

Note You need to log in before you can comment on or make changes to this bug.