Bug 1259867 - (CVE-2015-5250) CVE-2015-5250 OpenShift: Malformed JSON can cause API process crash
CVE-2015-5250 OpenShift: Malformed JSON can cause API process crash
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20150903,repor...
: Security
Depends On: 1258641
Blocks: 1259869
  Show dependency treegraph
 
Reported: 2015-09-03 12:46 EDT by Kurt Seifried
Modified: 2016-02-15 08:44 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
It was found that improper error handling in the API server could cause the master process to crash. A user with network access to the master could use this flaw to crash the master process.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 22:33:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Seifried 2015-09-03 12:46:35 EDT
Jordan Liggitt of the Red Hat OpenShift Team reports:

Malformed JSON can cause the OpenShift Master/Broker to exit unexpectedly.

External References:
https://github.com/openshift/origin/issues/4374

Acknowledgement:

Red Hat would like to thank Jordan Liggitt of the Red Hat OpenShift Team for reporting this issue.
Comment 1 errata-xmlrpc 2015-09-03 14:48:43 EDT
This issue has been addressed in the following products:

  RHEL 7 Version of OpenShift Enterprise 3.0

Via RHSA-2015:1736 https://access.redhat.com/errata/RHSA-2015:1736

Note You need to log in before you can comment on or make changes to this bug.