Bug 1259922 - Text install uses Alt+tab for switching tabs but that doesn't work via ssh
Text install uses Alt+tab for switching tabs but that doesn't work via ssh
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 15:42 EDT by Justin Garrison
Modified: 2016-03-08 16:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 15:40:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Garrison 2015-09-03 15:42:25 EDT
Description of problem:
When using inst.text and ssh to install systems the advertised method to switch tabs is with Alt+tab. That works for local console systems or via VMs with keyboard/mouse locked to the host. This does not, however, work for ssh installation sessions which alt+tab is special keybindings to the host. Likewise super+tab and ctrl+tab have special keybindings depending on the desktop environment and terminal emulator (if using tabs).
I know C-b n/p can be used but I think the default advertised window switching keys should be something that won't be captured by the host os or terminal emulator (with default settings at least).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enable ssh and text mode installer
2. SSH to building host and attach tmux instance
3. Try to alt+tab to switch windows.

Actual results:
Terminal window switches instead of tmux windows

Expected results:
tmux windows should switch

Additional info:
I'm not exactly sure what keyboard shortcut should be used but perhaps Ctrl+[1-5] or shift+tab? It may also be useful to enable mouse interaction for ssh users
set-window-option -g mode-mouse on # allows scrolling window history
set -g mouse-select-window on # allows selecting window tab
Comment 1 Jan Kurik 2016-02-24 08:42:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 David Shea 2016-03-08 15:40:57 EST
None of the possible solutions to this are good.

It's not that Alt-Tab is being caught by the window manager first and not sent to the ssh session, it's that Alt-Tab literally cannot be sent over the wire. Neither can Ctrl-1, neither can Shift-Tab, neither can the function keys (usually). Letting users switch windows with Alt-Tab is nice because it's familiar, and changing that to something that could be typed over any terminal type is likely to interfere with something that someone is going to try to type as text.

anaconda notes the Ctrl-B bindings in the help message displayed when started in environment that is unlikely to have a tty2 (s390, mostly). Changing the alt-tab message or the alt-tab behavior would make things worse for everyone else.
Comment 3 Justin Garrison 2016-03-08 16:16:35 EST
I ended up patching the tmux.conf with an updates.img file to switch the next/previous window in tmux to f6/f5 which worked well for us locally and via ssh.

Note You need to log in before you can comment on or make changes to this bug.