Bug 125995 - Installer hangs: Loading usb-storage driver...
Installer hangs: Loading usb-storage driver...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-14 19:11 EDT by Michael Torain
Modified: 2015-01-04 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:18:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Torain 2004-06-14 19:11:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
When attempting to install Fedora Core on a new hard drive (hdb) the
installer hangs on a blue screen. At the top is "Welcome to Fedora".
In a message box in the center: "Loading usb-storage device...".
Will not proceed past this point. Installed Fedora Core 2.0 onto 2
older Dells (GXa and GX1) from same media without incident.

Previous bug reporsts quoting similar wording: 121253 and 122397.

Note: Machine has a pci usb card "SIIG USB 2.0 Dual-Port PCI Host
   Adapter". Seems to have been recognized and configured by Kudzu in
   previous versions of Red Hat (7.2, 8.0, and 9.0 already existing
   and multi-booted on hdb). Booted with GRUB.

Hardware: Dell 4100, 800MHz CPU. Native USB 1.0. PCI USB 2.0

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1. Boot from Fedora Core 2.0 2.6.5-1.358 install media
2. Press ENTER at boot prompt
3.
    

Actual Results:  Installer hung on a blue screen. At the top is
"Welcome to Fedora".
In a message box in the center: "Loading usb-storage device...".
Will not proceed past this point.

Expected Results:  The installation should have proceeded normally.

Additional info:
Comment 1 Jeremy Katz 2004-06-14 20:56:51 EDT
Booting with 'linux nousbstorage' will avoid loading the usb-storage
driver as a workaround.
Comment 2 Michael Torain 2004-06-14 21:01:54 EDT
Additional information:

Using "boot: linux nousb" at the boot prompt will allow the
   installation to proceed to completion. However, once the
   install has completed and the system reboots, the 1st reboot
   after install will hang at "Checking for new hardware".
   Boot will not proceed. System appears to be unbootable.

 Three USB drivers appear to successfully load during bootup.
Comment 3 Michael Torain 2004-06-14 21:51:20 EDT
Additional information:

Removing the SIIG USB 2.0 Dual-Port PCI Host Adapter had no effect.
Bootup still hangs at "Checking for new hardware".
Comment 4 Michael Torain 2004-06-14 21:56:38 EDT
Additional information:

During bootup the following message appears:

agpgart: Detected an Intel i815 chipset but could not find the
   secondary device.
Comment 5 Michael Torain 2004-06-14 23:10:21 EDT
Will start new bug report concerning the hang at "Checking for new
hardware" during bootup.
Comment 6 Need Real Name 2004-09-07 12:38:09 EDT
Found the same problem with an Asus P4C800-E Deluxe motherboard with
an 875P chipset.  When I removed the USB connection to a Mitsumi 
FA402A Floppy Drive + 6 in 1 memory card reader, the problem went
away - strongly suggests there is some problem with driver support
for this product (it works fine under XP).  After completing 
installation I reconnected the USB port of the 6 in 1 memory card
reader (the Floppy Drive still is connected via IDE) and the system
runs fine; although, I have not tried to access any flash devices
through the 6 in 1 memory card reader - doubt it will work, but it's
not essential for my use.
Comment 7 Steven Bosscher 2004-10-06 13:29:15 EDT
I am seeing this problem on Intel's "Laguna" motherboard (Intel SDP 
D3x2600 series).  This board has the Intel 925X Chipset. 
 
So if it is the same bug, this problem is not i686 specific. 
 
Comment 8 dr 2004-11-23 12:52:44 EST
Have same issue with FC3 on an Asus P3 Via based motherboard with a
USB ECS 6 in 1 memory card reader. Installation stops with same message
directly after installing an Adaptec AHA 2940UW PCI scsi card driver. Probably
will work if I unplug the reader inside the case but I don't really feel I should have
to considering other distros work....currently installed Suse 9.1 is ok as are numerous
live cds I have tried.

..dr
Comment 9 Dave Jones 2005-04-16 00:18:27 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.