Bug 125996 - NFS should support NLM_MAXCOOKIELEN != 8 to work with OSX, BSD, etc
NFS should support NLM_MAXCOOKIELEN != 8 to work with OSX, BSD, etc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
http://www.fys.uio.no/~trondmy/src/Li...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-14 19:24 EDT by Damian Menscher
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:55:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Damian Menscher 2004-06-14 19:24:16 EDT
Description of problem:
NFS deals with cookies, which are typically, but not always, 8 bytes. 
 Linux had the 8-byte limit hard-coded in, which means we can't serve 
NFS to certain client OSes, such as OSX and fBSD.

There's a patch available at

http://www.fys.uio.no/~trondmy/src/Linux-2.4.x/2.4.23-rc1/linux-2.4.
23-03-fix_osx.dif

which resolves the problem.  It's been stable for me under RH9 and 
RHEL3 (I recompile the RPMs with this patch added), but it would be 
great to get this into the official release.


Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-15.EL

How reproducible:
Always

Steps to Reproduce:
1.  Try serving NFS to an OSX or fBSD client
Comment 1 Damian Menscher 2004-08-04 15:31:01 EDT
Changing severity from "enhancement" to "normal" since a functional 
NFSd is something to be expected.

[rant]There have been three kernel updates since I submitted this 
report.  It would be nice if someone could take the 2 minutes to 
apply the patch.[/rant]
Comment 2 Steve Dickson 2004-08-11 11:41:13 EDT
That's my fault.... Some how it slipped through the proverbial
cracks.... since this made into upstream I've turned everthing
on high to make sure this make the next update....

Comment 3 Tom "spot" Callaway 2004-08-22 13:48:20 EDT
Steve, is this fix liable to make it in U3?
Comment 4 Ernie Petrides 2004-08-23 10:58:33 EDT
Tom, no.  U3 closed a few weeks ago.
Comment 5 Ernie Petrides 2004-09-28 04:46:40 EDT
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-20.12.EL).
Comment 6 Damian Menscher 2004-09-28 11:40:20 EDT
Thank you!

Does this mean it will make it into security updates released before
U4, or will we have to keep recompiling until after U4?
Comment 7 Ernie Petrides 2004-09-28 22:11:01 EDT
There is no intention to include this fix in any possible security
update before u4 is released.
Comment 8 John Flanagan 2004-12-20 15:55:20 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.