Bug 1259996 - AttributeError: 'NameSpace' object has no attribute 'ra_certprofile' while ipa-ca-install
AttributeError: 'NameSpace' object has no attribute 'ra_certprofile' while ip...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 01:44 EDT by Abhijeet Kasurde
Modified: 2015-11-19 07:06 EST (History)
8 users (show)

See Also:
Fixed In Version: ipa-4.2.0-9.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:06:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installation log (9.41 KB, text/plain)
2015-09-04 01:44 EDT, Abhijeet Kasurde
no flags Details
fix_verification_log (8.38 KB, text/plain)
2015-09-15 07:31 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description Abhijeet Kasurde 2015-09-04 01:44:20 EDT
Created attachment 1070160 [details]
installation log

Description of problem:
ipa-ca-install fails with Python exception as 

AttributeError: 'NameSpace' object has no attribute 'ra_certprofile'

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-8.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create self-signed CA certificates using certutil command 
2. install ipa-server-install using this CA certificate
3. ipa-ca-install -p Secret123 -w Secret123 -U

Actual results:
AttributeError: 'NameSpace' object has no attribute 'ra_certprofile'

Expected results:
ipa-ca-install should be successfully

Additional info:
Comment 4 Martin Babinsky 2015-09-04 08:20:00 EDT
The error is caused by the fact that during installation of IPA master with external cert files, the option "ra_plugin" in IPA config file (/etc/ipa/default.conf) is set to "none".

Because of this, the dogtag-related backend plugins are not loaded during subsequent CA installation using 'ipa-ca-install', causing the last step of CA install to fail with AttributeError.

A workaround is to set "ra_plugin = dogtag" in /etc/ipa/default.conf before running ipa-ca-install.
Comment 5 Petr Vobornik 2015-09-04 08:59:04 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5288
Comment 9 Abhijeet Kasurde 2015-09-15 07:31:38 EDT
Created attachment 1073594 [details]
fix_verification_log
Comment 10 Abhijeet Kasurde 2015-09-15 07:38:47 EDT
Verified fix in IPA version  : ipa-server-4.2.0-9.el7.x86_64
Marking bug as verified.
Comment 11 errata-xmlrpc 2015-11-19 07:06:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.