Bug 1259998 - virt-manager tries to create vmport device on non-x86 backends
virt-manager tries to create vmport device on non-x86 backends
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
22
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 02:55 EDT by David Gibson
Modified: 2015-12-28 18:55 EST (History)
5 users (show)

See Also:
Fixed In Version: virt-manager-1.2.1-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 18:55:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Gibson 2015-09-04 02:55:23 EDT
Description of problem:

virt-manager tries to create a vmport (VMWare compatibility) device in a VM which doesn't use Spice, even if it is a non-x86 guest running on a non-x86 hypervisor which therefore can't support vmport.

Version-Release number of selected component (if applicable):

(virt manager host)

virt-manager-1.2.1-2.fc22.noarch
libvirt-1.2.13.1-2.fc22.x86_64

(remote hypervisor)

libvirt-daemon-1.2.17-7.el7.ppc64le
qemu-kvm-rhev-2.3.0-21.el7.ppc64le

How reproducible:

100%

Steps to Reproduce:
1. On an x86 machine add a virt-manager backend connecting to libvirt on a POWER8 server
2. Attempt to create new VM on the Power host
3. Deconfigure SPICE on the VM (since Spice is not supported on Power qemu)

Actual results:

VM creation fails with an error indicating that the qemu version doesn't support vmport.

Expected results:

VM is created and runs correctly.

Additional info:
Comment 1 Cole Robinson 2015-09-04 12:15:39 EDT
Thanks for the report, fixed upstream now:

commit 5e68b0fc3d9b93491817a3c1914fa9b3633440b6
Author: Cole Robinson <crobinso@redhat.com>
Date:   Fri Sep 4 12:14:22 2015 -0400

    guest: Don't try to set vmport on non-x86, it isn't supported (bz 1259998)
Comment 2 Fedora Update System 2015-11-25 15:28:14 EST
virt-manager-1.2.1-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-cdb691dcd9
Comment 3 Fedora Update System 2015-11-26 17:53:55 EST
virt-manager-1.2.1-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update virt-manager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cdb691dcd9
Comment 4 Fedora Update System 2015-11-27 20:15:26 EST
virt-manager-1.2.1-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ad893bbf01
Comment 5 Fedora Update System 2015-11-28 19:54:33 EST
virt-manager-1.2.1-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update virt-manager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ad893bbf01
Comment 6 Fedora Update System 2015-12-28 18:54:57 EST
virt-manager-1.2.1-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.