Bug 126 - Reboot after upgrade fails to mount
Reboot after upgrade fails to mount
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-18 18:44 EST by Stephen Vance
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-10 18:43:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Vance 1998-11-18 18:44:02 EST
After upgrading using the 5.2 distribution, non-root
filesystems were not remounted due to errors.  Removing
stale automounter entries in fstab restored the system to
full functionality.  This has happened on two upgrades with
distinctly different hardware.
Comment 1 Cristian Gafton 1998-11-18 21:24:59 EST
What are those "stale automounter entries in fstab" ?
Comment 2 Preston Brown 1998-11-19 12:01:59 EST
I've seen this as well.  If there are any
net: entries in fstab, you are totally screwed. mount fails horribly.
Comment 3 dmurphy 1998-11-20 18:34:59 EST
I encountered the same issue, and fixed it by commenting out the net
and automounter lines from /etc/fstab...
Comment 4 smm 1998-11-23 01:47:59 EST
Happened to me too.  I had in fstab "/dev/hda4 none ignore 0 0 0" for
an extended partition, and after the upgrade (from 5.0) mount did not
read fstab info for any entries below that.  I circumvented it by
moving the "stale entry" to be the last one.
Comment 5 Stephen Vance 1998-11-23 23:54:59 EST
It seems to only happen on SCSI systems.
Comment 6 dmurphy 1998-11-24 14:55:59 EST
Not true --- I have an all-IDE system!
Comment 7 Jay Turner 1998-12-08 16:36:59 EST
I have been able to verify this as a problem. I added the following
line to a working 5.0 install.

/dev/hda5	none		ignore	 	0 0 0

5.0 would boot up fine and mount all entries before and after this
line properly. I then did an upgrade to 5.2. When the machine came
back up, the partitions that I had listed in fstab after this line no
longer would mount. I removed the line and rebooted, everything
mounted properly.
Comment 8 Cristian Gafton 1998-12-10 18:43:59 EST
Invalid fstab entries will cause this behavior.
Mount will refuse to keep going when it reaches an invalid mount line
in order to avoid thrashing the machine because of the invalid
entries.

It is assumed that if the fstab is invalid/corrupted, then the safest
thing to do is to ignore it.

Kind of a pain sometimes, but there really isn't an alorithm of
deciding what to ignore from an invalid mount line.
Comment 9 seschveighoffer 1999-04-16 13:29:59 EDT
I had the same thing happen, but I would like to make a point, even
though you say it is a closed issue.  If a partition was a valid entry
in redhat 5.0-5.1 and a user upgrades to 5.2 (or at least upgrades the
mount package), shouldn't the system handle the changes?  I would also
like to note that the problem with my fstab is the "ignore" flag.  any
line with the "ignore" flag in it causes the rest of the fstab to
fail.  If you look at fstab's man page, ignore is a valid flag,
therefore, mount is failing on a VALID fstab file, not a corrupted or
invalid one.  If this is not the case (i.e. the ignore flag is no
longer supported) at the very least, the documentation should be
updated to reflect that.  If it is the case, mount should be fixed.

-Steve

Note You need to log in before you can comment on or make changes to this bug.