Bug 126001 - System crashes when switching from graphics mode to textmode
System crashes when switching from graphics mode to textmode
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2004-06-14 21:32 EDT by Andreas Thienemann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-06 17:37:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg-x11 config file from one of the crashing machines. (2.86 KB, text/plain)
2004-07-13 07:25 EDT, Andreas Thienemann
no flags Details
Xorg log (273.77 KB, text/plain)
2004-07-13 07:28 EDT, Andreas Thienemann
no flags Details
lspci output of the first box (4.06 KB, text/plain)
2004-07-21 03:43 EDT, Andreas Thienemann
no flags Details
gkodinov's xinerama xorg.conf (6.68 KB, text/plain)
2004-11-11 11:47 EST, George Kodinov
no flags Details

  None (edit)
Description Andreas Thienemann 2004-06-14 21:32:43 EDT
Description of problem:
When switching from graphics mode to textmode by hitting CTRL-ALT-F1
the system locks up.
The screen stays black, the monitor does not audible click as it does
when normaly when switching to textmode and if some kind of sound is
currently playing it loops.

Version-Release number of selected component (if applicable):

How reproducible:

The problem is always reproducible, however, I can't link it to some
specific action. Sometimes it happens after several hours of uptime,
sometimes after a few minutes.

The problem does present itself on different systems with different
graphic hardware (Matrox G400, a Matrox G400DH and a ATI Rage 128)
leading me to believe it is not related to a specific kind of video

Is there any advice on how to sucessfully debug this problem? After
the system hangs I do not get any useful data in the logs.
Comment 1 Mike A. Harris 2004-07-07 03:20:39 EDT
Please attach your X server log from after a crash/problem.  Be sure
to make a backup copy of the log before starting up the X server or
the new invocation will overwrite the old log from the crash.

Also attach your config file and /var/log/messages.  Each attachment
should be using the link below, and uncompressed.

Thanks in advance.
Comment 2 Andreas Thienemann 2004-07-08 09:57:53 EDT
The X server log is useless as the crash prevents any error from being
written to the log.

Config file is attached.

However, it seems that xorg-x11-6.7.0-5 fixes the problem, which seems
to be:

* Sat Jun 26 2004 Mike A. Harris <mharris@redhat.com> 6.7.0-5
- Fixed bug in mga driver which caused hangs on some Matrox Mystique    
  boards of revision 0->2, which were caused by a previous upstream
  bugfix for another issue.  xorg-x11-6.7.0-mga-storm-sync-fix.patch

I'll do some further testing however to make sure the crashes really
Comment 3 Andreas Thienemann 2004-07-13 07:24:43 EDT
Well. The crashes still occur.
The update didn't change anything as it first seemed.

Attaching /var/log/messages config and Xorg.0.log, although I do not
see anything useful in them.
Comment 4 Andreas Thienemann 2004-07-13 07:25:23 EDT
Created attachment 101856 [details]
Xorg-x11 config file from one of the crashing machines.
Comment 5 Andreas Thienemann 2004-07-13 07:28:43 EDT
Created attachment 101857 [details]
Xorg log
Comment 6 Andreas Thienemann 2004-07-13 07:30:09 EDT
skipped attaching /var/log/messages as it says nothing short of
mentioning that the kernel is booting because the box was rebooted
after the crash.
Comment 7 Barry K. Nathan 2004-07-19 23:19:02 EDT
Have you tried testing with a serial console?

Is the crashing graphics hardware AGP or PCI? Did the problem happen
with any previous Linux distributinos? If not, try installing a Red
Hat 9, Fedora Core 1, White Box Enterprise Linux, CentOS 3.x, Tao
Linux, or Red Hat Enterprise Linux kernel (you may need to edit
/etc/X11/xorg.conf to use /dev/psaux instead of /dev/input/mice again,
if you are using a PS/2 mouse)?

(You should be able to install one of those kernels using "rpm -ivh
--oldpackage name-of-kernel.ix86.rpm".)

OBTW, even if the final crash information isn't getting into
/var/log/messages, attaching it may be helpful anyway! Even if you
can't see anything useful in it, somebody else might. :)

It may also be useful to attach "/sbin/lspci -vvxxx" output from *all
three* affected machines. (Doing it from all 3 may show us some kind
of common link between the machines.)
Comment 8 Andreas Thienemann 2004-07-21 03:43:07 EDT
Nope. No access to a serial console until now. I will test it however.

The Matrox G400 is only available as AGP.

No the systems worked flawlessly with _each_ single version and beta
up to and including FC1, starting with RH6.0 or so...

I'll try a different kernel however...

There is no accessible crash information in the logs. None as in,
nonexisting, not as in not-recognizable by me. :-)

The system crashes before anything can be written to the syslog.

lspci output is attached.
Comment 9 Andreas Thienemann 2004-07-21 03:43:49 EDT
Created attachment 102097 [details]
lspci output of the first box
Comment 10 George Kodinov 2004-11-11 11:45:12 EST
I have the same problem with an radeon 9200 running in xinerama mode.
If I turn the xinerama off the problem goes away.

BTW, the system-config-display won't turn the xinerama back on once
turned off (lucky for me I had my original xorg.conf saved :-).
Attaching my xorg.conf
Comment 11 George Kodinov 2004-11-11 11:47:14 EST
Created attachment 106510 [details]
gkodinov's xinerama xorg.conf

this one hangs the PC when I do Ctrl-Alt-F1
Comment 12 Robert Jackson 2004-12-13 13:49:36 EST
I had the same problem on FC3 with a Matrox G400.

The computer had previously been running Mandrake Linux 9.0 (with a
2.4 series kernel), without any problems.

With FC3, the system would completely lockup when switching from
graphical mode to text mode, or when running system-config-display.

There was nothing useful in the system logs as the system would
completely freeze before anything was appended to the log.

I tried updating everything to the latest version, but to no avail.

As a last resort, I updated the bios on the graphics card and
miraculously this solved all my problems.


Hope this helps.
Comment 13 Mike A. Harris 2005-03-06 17:37:32 EST
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:


If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.