Bug 1260011 - SELinux is preventing abrt-hook-ccpp from using the 'sigchld' accesses on a process.
SELinux is preventing abrt-hook-ccpp from using the 'sigchld' accesses on a p...
Status: CLOSED DUPLICATE of bug 1242467
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ee92e20c4a93c317476200fdecc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 03:30 EDT by Joachim Frieben
Modified: 2015-09-11 06:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 06:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2015-09-04 03:30:48 EDT
Description of problem:
SELinux is preventing abrt-hook-ccpp from using the 'sigchld' accesses on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed sigchld access on processes labeled kernel_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:system_r:kernel_t:s0
Target Objects                Unknown [ process ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-146.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.0-1.fc23.x86_64 #1 SMP Mon Aug
                              31 15:57:27 UTC 2015 x86_64 x86_64
Alert Count                   5
First Seen                    2015-09-03 07:15:40 CEST
Last Seen                     2015-09-04 09:25:48 CEST
Local ID                      ea8a4180-65a7-4ec3-8803-2be61a3a3347

Raw Audit Messages
type=AVC msg=audit(1441351548.362:677): avc:  denied  { sigchld } for  pid=27658 comm="abrt-hook-ccpp" scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=process permissive=0


Hash: abrt-hook-ccpp,NetworkManager_t,kernel_t,process,sigchld

Version-Release number of selected component:
selinux-policy-3.13.1-146.fc23.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.0-1.fc23.x86_64
type:           libreport

Potential duplicate: bug 1245756
Comment 1 Miroslav Grepl 2015-09-11 06:29:00 EDT

*** This bug has been marked as a duplicate of bug 1242467 ***

Note You need to log in before you can comment on or make changes to this bug.