Bug 1260020 - rpcbind can not be started if rpc user not present in /etc/passwd (problem on Atomic)
rpcbind can not be started if rpc user not present in /etc/passwd (problem on...
Status: CLOSED DUPLICATE of bug 1171291
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpcbind (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Filesystem QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 04:07 EDT by Fabian Deutsch
Modified: 2015-09-04 08:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-04 08:41:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2015-09-04 04:07:15 EDT
Description of problem:
If rpc is in a tree on Atomic, then it won't start, because it seems that it is directly (not indirectly through libs) checking that the rpc user exists in /etc/passwd.
But as users are in /usr/lib/passwd on Atomic, rpcbind refuses to start:

Logs:
Aug 31 08:46:38 atomic01.example.org systemd[1]: Starting RPC bind service...
Aug 31 08:46:38 atomic01.example.org systemd[1]: Started RPC bind service.
Aug 31 08:46:38 atomic01.example.org rpcbind[776]: cannot get uid of 'rpc': Success
Aug 31 08:46:38 atomic01.example.org systemd[1]: rpcbind.service: main process exited, code=exited, status=1/FAILURE
Aug 31 08:46:38 atomic01.example.org systemd[1]: Unit rpcbind.service entered failed state.


Version-Release number of selected component (if applicable):
# rpm -q rpcbind
rpcbind-0.2.0-26.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
To make it work:

# cat /etc/passwd
root:x:0:0:root:/root:/bin/bash
centos:x:1000:1000:Cloud User:/home/centos:/bin/bash

# grep rpc /usr/lib/passwd >> /etc/passwd

# service rpcbind restart
Redirecting to /bin/systemctl restart  rpcbind.service
# systemctl status rpcbind
rpcbind.service - RPC bind service
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; static)
   Active: active (running) since Fr 2015-09-04 07:56:14 UTC; 4s ago
  Process: 13656 ExecStart=/sbin/rpcbind -w ${RPCBIND_ARGS} (code=exited, status=0/SUCCESS)
 Main PID: 13657 (rpcbind)
   CGroup: /system.slice/rpcbind.service
           └─13657 /sbin/rpcbind -w
Comment 1 Colin Walters 2015-09-04 08:14:10 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=1171291
Comment 2 Fabian Deutsch 2015-09-04 08:41:56 EDT

*** This bug has been marked as a duplicate of bug 1171291 ***

Note You need to log in before you can comment on or make changes to this bug.