Bug 126003 - Gaim MSN protocol no longer works over proxy servers
Summary: Gaim MSN protocol no longer works over proxy servers
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gaim   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Reed
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-15 01:41 UTC by Darryl Dixon
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-31 08:58:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Darryl Dixon 2004-06-15 01:41:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Since upgrading to FC2 gaim is no longer able to use the MSN protocol
over either an HTTP or SOCKS proxy server.  It fails during the
'Syncing with server' phase with:
"""
username@hotmail.com has been disconnected.

Tue Jun 15 13:37:38 2004
Error reading from Notification server. Lastcommand was:
 Ver 1 MSNP9 MSNP8 CVR0
"""


Version-Release number of selected component (if applicable):
gaim-0.78-1.FC2

How reproducible:
Always

Steps to Reproduce:
1.Upgrade gaim to latest release
2.Setup MSN account with either HTTP or SOCKS proxy defined
3.Attempt to connect
    

Actual Results:  Times out during 'Syncing with server' phase

Expected Results:  Connects successfully

Additional info:

Comment 1 Darryl Dixon 2004-06-15 02:38:03 UTC
Further to this; having performed a network dump, here's what it's doing:
1) Standard DNS query for messenger.hotmail.com (returns 207.46.104.20)
2) It initiates a SOCKS Command 1 (Connect) to port 80 on
207.46.104.20 containing the following data payload:
VER  1 MSNP9 MSNP8 CVR0       
 -- After which the connection simply seems to time out.
3) If using HTTP proxy *it doesn't issue a CONNECT at all*, instead
simply sending the 'VER  1 MSNP9 MSNP8 CVR0' string directly to the
proxy server (ie, it's braindead).

Summary, the SOCKS code its using is somewhat braindead, the HTTP
proxy code its using it UTTERLY braindead.  For comparison, using gaim
to connect an ICQ account with the same HTTP proxy settings works
correctly and a network dump clearly shows the CONNECT command being
executed against the proxy server, etc...


Comment 2 Darryl Dixon 2004-07-17 08:36:44 UTC
It works if 'Use HTTP method' under 'Show more options' is ticked as
of gaim-0.79-0.FC2.


Note You need to log in before you can comment on or make changes to this bug.