Bug 1260051 - DHT: Few files are missing after remove-brick operation
DHT: Few files are missing after remove-brick operation
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
: ZStream
Depends On: 1259750
Blocks: 1262197
  Show dependency treegraph
 
Reported: 2015-09-04 06:09 EDT by Susant Kumar Palai
Modified: 2016-06-16 09:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1259750
: 1262197 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:35:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-09-04 06:12:56 EDT
REVIEW: http://review.gluster.org/12105 (dht/remove-brick: Avoid data loss for hard link migration) posted (#1) for review on master by Susant Palai (spalai@redhat.com)
Comment 2 Vijay Bellur 2015-09-09 06:37:33 EDT
REVIEW: http://review.gluster.org/12105 (dht/remove-brick: Avoid data loss for hard link migration) posted (#2) for review on master by Susant Palai (spalai@redhat.com)
Comment 3 Vijay Bellur 2015-09-09 08:04:14 EDT
REVIEW: http://review.gluster.org/12105 (dht/remove-brick: Avoid data loss for hard link migration) posted (#3) for review on master by Susant Palai (spalai@redhat.com)
Comment 4 Vijay Bellur 2015-09-11 06:16:43 EDT
REVIEW: http://review.gluster.org/12160 (dht/cluster: Avoid crash if local is NULL) posted (#1) for review on master by Susant Palai (spalai@redhat.com)
Comment 5 Vijay Bellur 2015-09-11 08:56:35 EDT
REVIEW: http://review.gluster.org/12160 (dht/cluster: Avoid crash if local is NULL) posted (#2) for review on master by Susant Palai (spalai@redhat.com)
Comment 6 Vijay Bellur 2015-09-14 01:48:54 EDT
COMMIT: http://review.gluster.org/12160 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit c31ac73cd8e9ca4b872a48667e09019991dea00b
Author: Susant Palai <spalai@redhat.com>
Date:   Fri Sep 11 08:52:44 2015 -0400

    dht/cluster: Avoid crash if local is NULL
    
    This patch addresses crash handling if local is NULL. In addition to that,
    we were not unwinding if no lock is taken in dht_linkfile_create_cbk(create/mknod).
    This patch handles that also.
    
    Change-Id: Ibcff317f10d60e7865fd7ffb9479b3af53c9ef17
    BUG: 1260051
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/12160
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 7 Kaleb KEITHLEY 2015-10-22 13:00:12 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 8 Kaleb KEITHLEY 2015-10-22 13:06:51 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 9 Kaleb KEITHLEY 2015-10-22 13:11:18 EDT
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.
Comment 10 Niels de Vos 2016-06-16 09:35:09 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.