Bug 1260072 - Cantarell font hinting is broken. Replace it?
Cantarell font hinting is broken. Replace it?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gsettings-desktop-schemas (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 07:17 EDT by Christian Stadelmann
Modified: 2016-06-27 11:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-27 11:24:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-09-04 07:17:14 EDT
Description of problem:
The default font in Gnome 3.x is Cantarell. This font doesn't seem to support hinting at all. You can see the difference if you compare it to e.g. the liberation fonts.

Version-Release number of selected component (if applicable):
abattis-cantarell-fonts-0.0.16-2.fc22.noarch
0.0.16-3.fc23

How reproducible:
always

Steps to Reproduce:
1. open gnome-tweak-tool
2. set hinting to "Medium" or "Full"
3. look at the font face

Actual results:
Font doesn't seem to do any hinting at all.

Expected results:
Font should look nice and clean with hinting enabled, just as e.g. Liberation Sans does.

Additional info:
Bug reports against Cantarell:
https://bugzilla.redhat.com/show_bug.cgi?id=1035486
https://bugzilla.redhat.com/show_bug.cgi?id=1062903
Comment 1 Matthias Clasen 2015-09-08 14:45:12 EDT
That argument does not make much sense.to me. The default font needs to work well with the default font rendering settings. It does not follow that it is somehow unsuitable because it doesn't work equally well with _all_ possible font rendering settings.

But in any case, we are investigating replacing Cantarell as the default font (for other reasons).
Comment 2 Christian Stadelmann 2016-06-27 11:24:00 EDT
Cantarell was improved for Gnome 3.20 / Fedora 24 release, it is working good now. Thank you!

Note You need to log in before you can comment on or make changes to this bug.