Bug 1260097 - kdc component installation of IPA failed (7.1z-stream)
kdc component installation of IPA failed (7.1z-stream)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.1
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: Regression, TestBlocker
Depends On: 1241941
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 08:12 EDT by Xiyang Dong
Modified: 2015-09-04 10:47 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1241941
Environment:
Last Closed: 2015-09-04 10:47:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ipaserver-install.log (282.09 KB, text/plain)
2015-09-04 08:24 EDT, Xiyang Dong
no flags Details

  None (edit)
Comment 3 Xiyang Dong 2015-09-04 08:24:17 EDT
Created attachment 1070243 [details]
ipaserver-install.log
Comment 4 Xiyang Dong 2015-09-04 08:28:17 EDT
Version-Release number of selected component (if applicable):
[root@cisco-c210-01 ~]# rpm -q ipa-server krb5-server 
ipa-server-4.1.0-18.el7.x86_64
krb5-server-1.13.2-9.el7.x86_64
Comment 5 Petr Vobornik 2015-09-04 08:34:48 EDT
Xiang, 

to verify that it's really the same issue, could you run following commands on the host with the failed installation:

$ kadmin.local -q addprinc -randkey ldap/cisco-c210-01.testrelm.test@TESTRELM.TEST -x ipa-setup-override-restrictions
$ systemctl status kadmin.service
$ systemctl restart kadmin.service

If it's the bug, we should see some of these outputs:
1. after kadmin.local:
kadmin.local: Unsupported argument "ipa-setup-override-restrictions" for db2 while initializing kadmin.local interface

2. after systemctl start kadmin.service:
kadmind: kadmind: Database module does not match KDC version while initializing, aborting
Comment 9 Xiyang Dong 2015-09-04 10:47:10 EDT
Thanks Petr, I'll go ahead and close this bz as not a bug

Note You need to log in before you can comment on or make changes to this bug.