This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1260111 - Docker is appending 'carriage return' char. at the end of each line if --tty is set
Docker is appending 'carriage return' char. at the end of each line if --tty ...
Status: CLOSED DUPLICATE of bug 1260113
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: smahajan@redhat.com
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1260113
  Show dependency treegraph
 
Reported: 2015-09-04 08:30 EDT by Peter Hostačný
Modified: 2016-07-31 21:06 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1260113 (view as bug list)
Environment:
Last Closed: 2015-10-01 10:55:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hostačný 2015-09-04 08:30:09 EDT
Description of problem:
Running docker run with '-t' flag is printing output with carriage return character at the end of each line. Command launched in container prints an output with normal linux-like line ending, but docker changes it after redirecting output from container to host console.


Version-Release number of selected component (if applicable):
Docker version 1.7.1.fc22, build b6416b7/1.7.1

How reproducible:
Always

Steps to Reproduce:
1. $ docker run -t --rm ubuntu:12.04 bash -c 'echo something' | od -c
2.
3.

Actual results:
0000000   s   o   m   e   t   h   i   n   g  \r  \n
0000013


Expected results:
0000000   s   o   m   e   t   h   i   n   g  \n
0000012


Additional info:
https://github.com/docker/docker/issues/8513
Comment 1 smahajan@redhat.com 2015-10-01 10:55:23 EDT
Duplicate of 1260113.
https://bugzilla.redhat.com/show_bug.cgi?id=1260113

Closing this one.

*** This bug has been marked as a duplicate of bug 1260113 ***

Note You need to log in before you can comment on or make changes to this bug.