Bug 1260132 - No (useful) way to configure time- and other formats.
No (useful) way to configure time- and other formats.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: plasma-workspace (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 09:50 EDT by Stefan Seefeld
Modified: 2015-09-04 10:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-04 09:57:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Seefeld 2015-09-04 09:50:57 EDT
The only way to change the display format of date/time, numbers, measurement units, etc., is by changing the locale.

That seem very wrong. (Example: how can I switch to 24-hour displays, using ISO formatting for dates, using metric units, etc., without affecting the language settings ?)

The localization GUI of the KDE plasma seems to be ill-designed.
Comment 1 Rex Dieter 2015-09-04 09:57:09 EDT
That's simply currently how it is designed (and we downstream can't fix that).

See also:
http://vizzzion.org/blog/2014/05/locale-changes-in-plasma-next/

But some things are possible, example:
"Wish: ISO8601 Date Format display option"
https://bugs.kde.org/show_bug.cgi?id=348080
Comment 2 Stefan Seefeld 2015-09-04 10:02:38 EDT
Yes, I understand that this is a design bug. But that doesn't make it less of a bug. :-)

Thanks for the suggestions, though.

Note You need to log in before you can comment on or make changes to this bug.