Bug 126014 - screaming interrupt - lose network after logging out of X
screaming interrupt - lose network after logging out of X
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-06-15 07:03 EDT by John Horne
Modified: 2015-01-04 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-04 13:49:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
"lspci -vv" output (8.26 KB, text/plain)
2004-06-15 07:05 EDT, John Horne
no flags Details

  None (edit)
Description John Horne 2004-06-15 07:03:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:

I installed FC2 onto my work PC, which ran RH9 for a long time with no
problems. The PC is used during the day; logged out in the evening but
left running over night; next morning I just log in again.

When I log out of X in the evening I lose the network connection
because the interupt is disabled. This happens each time I logout, so
I now logout; press CTRL-ALT-F1; login as root and reboot (then just
leave the PC overnight).

The system is a Research Machine (RM) PC with an Intel 2GHz cpu; 512MB
memory. It has two 20GB disks which are software raided (level 1 -
just mirroring). Each disk is on its own controller - one on the RM
controller; the other on a Promise Ultra 133 controller. The system
also has a 100MB zip drive and a CD/RW. It has an ATI Rage Pro Ultra
graphics card. It also has an Intel Pro 100 network card (builtin as
far as I remember). Sound is also from the onboard sound controller.

The kernel log has the message:

Jun 14 17:31:12 jhorne kernel: irq 11: nobody cared! (screaming
Jun 14 17:31:12 jhorne kernel: Stack pointer is garbage, not printing
Jun 14 17:31:12 jhorne kernel: handlers:
Jun 14 17:31:12 jhorne kernel: [<02216a58>] (usb_hcd_irq+0x0/0x4b)
Jun 14 17:31:12 jhorne kernel: [<22974c7b>] (e100_intr+0x0/0xe6 [e100])
Jun 14 17:31:12 jhorne kernel: [<22d234eb>]
Jun 14 17:31:12 jhorne kernel: Disabling IRQ #11

uname shows:

Linux jhorne 2.6.6-1.427 #1 Thu Jun 10 09:33:46 EDT 2004 i686 i686
i386 GNU/Linux

/proc/interrupts shows (whilst the network is working):

{john}4: cat /proc/interrupts
  0:   65769478          XT-PIC  timer
  1:       6506          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  3:          0          XT-PIC  uhci_hcd
  5:          0          XT-PIC  uhci_hcd
  8:          1          XT-PIC  rtc
  9:          0          XT-PIC  acpi, ehci_hcd
 10:     103872          XT-PIC  ide2
 11:    6209437          XT-PIC  uhci_hcd, eth0, r128@PCI:1:0:0, Intel
 12:     145291          XT-PIC  i8042
 14:     106019          XT-PIC  ide0
 15:        829          XT-PIC  ide1
NMI:          0
ERR:          0

The system is booted with the kernel command line of:

   ro root=/dev/md2 idebus=66

I saw some other people reporting similar 'screaming interrupt'
problems but the later kernels seem to have fixed those. I have tried
using noacpi and pci=noacpi when booting but they made no difference -
the system still lost the interrupt.

I'll attach a 'lspci -vv' output to this report.

That's it,


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Logout of X from this PC.

Actual Results:  Access to the network was lost; kernel log shows
scraming interrupt message. Rebooting the PC restores the network
connection until I next login and then out of X.

Expected Results:  Nothing should have happened - the network
connection should still be present when I logout.

Additional info:
Comment 1 John Horne 2004-06-15 07:05:28 EDT
Created attachment 101136 [details]
"lspci -vv" output
Comment 2 Ralph Jones 2004-08-18 23:39:51 EDT
I have the same problem: Interrupt 11 gets turned off when I log off
an X username, and the network card stays down until the system is
rebooted. Messages file shows:

Aug 15 09:43:51 heloise gconfd (root-3058): Exiting
Aug 15 09:43:53 heloise kernel: irq 11: nobody cared! (screaming
Aug 15 09:43:53 heloise kernel: irq 11: Please try booting with
acpi=off and report a bug
Aug 15 09:43:53 heloise kernel: Stack pointer is garbage, not printing
Aug 15 09:43:53 heloise kernel: handlers:
Aug 15 09:43:53 heloise kernel: [<128be97c>]
(tulip_interrupt+0x0/0x774 [tulip])
Aug 15 09:43:53 heloise kernel: Disabling IRQ #11
Aug 15 09:43:53 heloise kernel: agpgart: Found an AGP 2.0 compliant
device at 0000:00:00.0.

I've tried rebooting with acpi=off per the message, but that doesn't help.

Ralph Jones
Comment 3 John Horne 2005-01-04 12:16:09 EST
I upgraded to Fedora Core 3 some time ago and still had this problem.
However, with kernels 2.6.9-1.681_FC3 and the latest 2.6.9-1.724_FC3
the problem seems to have gone! I have successfully logged out of X
and back in and still had a network connection. Also logging out of X
and then to a virtual console I still have a network connection. So at
least for FC3 this problem seems to be fixed.

Note You need to log in before you can comment on or make changes to this bug.