Bug 1260141 - Unnecessary tasks generated and spawned during content view publish: 100k steps
Unnecessary tasks generated and spawned during content view publish: 100k steps
Status: CLOSED DUPLICATE of bug 1372073
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity high (vote)
: 6.2.4
: --
Assigned To: Ivan Necas
jcallaha
: PrioBumpField, Triaged
: 1374771 (view as bug list)
Depends On:
Blocks: 1353215 1386429 1386449
  Show dependency treegraph
 
Reported: 2015-09-04 10:12 EDT by Justin Sherrill
Modified: 2017-04-25 12:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1386449 (view as bug list)
Environment:
Last Closed: 2016-10-28 10:28:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16499 None None None 2016-09-14 14:50 EDT
Red Hat Knowledge Base (Solution) 2755731 None None None 2016-11-07 12:30 EST

  None (edit)
Description Justin Sherrill 2015-09-04 10:12:40 EDT
Description of problem:

During content view publish there are a number of 'update schedule' tasks that are executing within the publish task that are not needed.  These are setting the schedule on the Library repos.

In addition, whenever publishing any repositories that are being created are having a task spawned off that does a yum metadata publish.  At this point the repos are empty so this does not take very long (less than a second), but it can cause many tasks to be spawned.

Version-Release number of selected component (if applicable):
6.1.1

How reproducible:
Always

Steps to Reproduce:
1. Create a product with 5 repos.
2. Add the product to a sync plan
3. Create a content view and add all 5 repos.
4. Publish the content view.

Actual results:

a) within the 'publish' task of the dynflow console you'll see 5 'UpdateSchedule' tasks.

b) Within Monitor > Tasks you will see 5 MetadataGenerate tasks.


Expected results:

You should see neither a) nor b)
Additional info:
Comment 1 Justin Sherrill 2015-09-04 10:14:29 EDT
Since this does not seem to cause any actual performance issues, i'm not sure this needs to be a zstream.
Comment 3 Bryan Kearney 2016-07-08 16:47:47 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 5 Brad Buckingham 2016-08-24 16:13:28 EDT
Created redmine issue http://projects.theforeman.org/issues/16274 from this bug
Comment 6 Bryan Kearney 2016-09-14 16:09:59 EDT
Upstream bug assigned to inecas@redhat.com
Comment 7 Bryan Kearney 2016-09-14 16:10:02 EDT
Upstream bug assigned to inecas@redhat.com
Comment 8 Bryan Kearney 2016-09-20 20:09:19 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/16499 has been resolved.
Comment 12 Mike McCune 2016-10-20 17:43:30 EDT
*** Bug 1374771 has been marked as a duplicate of this bug. ***
Comment 13 Zach Huntington-Meath 2016-10-28 10:28:51 EDT

*** This bug has been marked as a duplicate of bug 1372073 ***

Note You need to log in before you can comment on or make changes to this bug.