Bug 1260157 - vmwgfx segfault when restarting NetworkManager
vmwgfx segfault when restarting NetworkManager
Status: CLOSED DUPLICATE of bug 1227193
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 11:16 EDT by fulminemizzega
Modified: 2015-09-04 16:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-04 16:51:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fresh f22 dmesg, kernel 4.0.4 (126.73 KB, text/plain)
2015-09-04 11:16 EDT, fulminemizzega
no flags Details
fresh f22 journal, kernel 4.0.4 (737.46 KB, text/x-vhdl)
2015-09-04 11:17 EDT, fulminemizzega
no flags Details
loginctl output (637 bytes, text/plain)
2015-09-04 11:18 EDT, fulminemizzega
no flags Details
updated f22 dmesg, kernel 4.1.6 (117.20 KB, text/plain)
2015-09-04 11:30 EDT, fulminemizzega
no flags Details
updated f22 journal, kernel 4.1.6 (565.84 KB, text/x-vhdl)
2015-09-04 11:31 EDT, fulminemizzega
no flags Details

  None (edit)
Description fulminemizzega 2015-09-04 11:16:23 EDT
Created attachment 1070323 [details]
fresh f22 dmesg, kernel 4.0.4

Description of problem:
Fedora 22 Workstation inside VMWare Workstation on Windows (vers 10, 11 tested) has weird issues when restarting NetworkManager, dmesg shows segfault [...] in vmwgfx_dri.so. Restarting NetworkManager (or even issuing nmcli networking off) brings back to gdm login. I think the old session remains active, but I can't access to it, I need to login another time, by looking at loginctl. The issue is present both in fresh f22 install and also after dnf upgrade and reboot into new kernel.

Version-Release number of selected component (if applicable):
Fedora 22 Workstation
kernel-4.0.4-301.fc22
kernel-4.1.6-.fc22
VMWare Workstation 10, 11 for Windows

How reproducible: always


Steps to Reproduce:
1. Create a VM with VMware workstation 10 or 11 of F22 Workstation
2. Run systemctl restart NetworkManager (or nmcli networking off)
3. Check dmesg

Actual results: UI session is kicked back to login


Expected results: vmwgfx should not segfault when restarting nm...


Additional info: see attachments
Comment 1 fulminemizzega 2015-09-04 11:17:24 EDT
Created attachment 1070324 [details]
fresh f22 journal, kernel 4.0.4
Comment 2 fulminemizzega 2015-09-04 11:18:13 EDT
Created attachment 1070325 [details]
loginctl output
Comment 3 fulminemizzega 2015-09-04 11:30:29 EDT
Created attachment 1070328 [details]
updated f22 dmesg, kernel 4.1.6

This is how I obtained this:
Started VM, login, systemctl restart NetworkManager
screen flickers, goes back to GDM, then back to previous session (I can see same terminal open). Then issuing again systemctl restart NetworkManager, back to GDM, trying to login but then displays stays black, back to TTY, login as root, restart GDM, then I'm able to get this. Same goes for following journal attachment.
Comment 4 fulminemizzega 2015-09-04 11:31:13 EDT
Created attachment 1070329 [details]
updated f22 journal, kernel 4.1.6
Comment 5 fulminemizzega 2015-09-04 11:42:30 EDT
Sorry, I missed one step:
Started VM, login, systemctl restart NetworkManager
screen flickers, goes back to GDM, *THEN* pressing Ctrl+Alt+F2 I'm able to go back to previous session.
I'm not able to do the same the second time, instead after pressing Ctrl+Alt+F2 I only get to an empty console.
Comment 6 Josh Boyer 2015-09-04 13:05:05 EDT
Isn't this the same as bug 1227193 ?
Comment 7 fulminemizzega 2015-09-04 13:10:49 EDT
Hello Josh,
it looks really similar, the only difference is that here I'm able to trigger it by restarting networkmanager or with nmcli (and I don't understand how the two things can be related). I'm going to update to F23 and test with kernel-4.2.0-1.fc23
Comment 8 fulminemizzega 2015-09-04 15:36:26 EDT
Josh,
I'm sorry to have bothered you and the other maintainers, the issue I reported here is clearly gone, on fedora 23 with kernel 4.2.0-1.fc23 everything is ok.
You can close this bug.
Comment 9 Josh Boyer 2015-09-04 16:51:01 EDT
No problem at all.  Thank you for reporting.

*** This bug has been marked as a duplicate of bug 1227193 ***

Note You need to log in before you can comment on or make changes to this bug.