Bug 1260159 - Languages in menu shown as "unknown"
Languages in menu shown as "unknown"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 11:19 EDT by David Juran
Modified: 2015-09-25 06:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-3.16.5-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 06:54:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (142.93 KB, image/jpeg)
2015-09-04 11:19 EDT, David Juran
no flags Details

  None (edit)
Description David Juran 2015-09-04 11:19:35 EDT
Created attachment 1070326 [details]
screenshot

Description of problem:
Recently (fedora 22, this used to work in fedora 21), the languages in the menu are shown as unknown, see attached screen shot.

Version-Release number of selected component (if applicable):
evolution-3.16.5-1.fc22.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Start a new email
2. Edit -> Current languages
3. Where is now says "unknown" previously the name of the language was printed out
Comment 1 Milan Crha 2015-09-07 06:18:18 EDT
Thanks for a bug report. Evolution uses iso-codes package to get user readable names for the languages. It opens /usr/share/xml/iso-codes/iso_639.xml and .../iso_3166.xml for this purpose (it's the former, the later is for other parts). That it writes "Unknown (language_code)" means the lookup in the ISO 639 failed for that particular code.

I looked into the iso-codes package and both files are there. Could it be that you do not have the iso-codes package installed?
Comment 2 David Juran 2015-09-07 13:25:46 EDT
iso-codes is installed:

[djuran@localhost Jeppesen]$ rpm -q iso-codes
iso-codes-3.57-1.fc22.noarch


Also the files 
/usr/share/xml/iso-codes/iso_639.xml and /usr/share/xml/iso-codes/iso_639.xml are there and are readable.

strace -e open of the evolution process however suggests that these files never are accessed.
Comment 3 Milan Crha 2015-09-08 01:32:58 EDT
Aah, I see. The koji build shows that only iso-codes package had been brought in, not iso-codes-devel, thus the configure ended with:
   checking for iso-codes package... no

I'll fix the spec file. The previous versions had this done properly due to iso-codes-devel being brought in indirectly, through gtkhtml3. Evolution doesn't depend on that package anymore, thus it lost it.
Comment 4 Fedora Update System 2015-09-08 04:31:15 EDT
evolution-3.16.5-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15301
Comment 5 Fedora Update System 2015-09-08 17:25:54 EDT
evolution-3.16.5-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update evolution'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15301
Comment 6 Fedora Update System 2015-09-25 06:54:05 EDT
evolution-3.16.5-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.