Bug 1260165 - undercloud.conf.sample comments should match documentation
undercloud.conf.sample comments should match documentation
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
All All
medium Severity low
: ---
: 10.0 (Newton)
Assigned To: James Slagle
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 11:43 EDT by Dan Yocum
Modified: 2016-10-17 05:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-17 05:13:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2015-09-04 11:43:10 EDT
Description of problem:

Several comment sections in the undercloud.conf.sample file don't match the documentation in the guide.  The undecloud.conf needs to be updated.

For example, the conf file says:

# Network CIDR for the Neutron-managed network for Overcloud
# instances. This should be the subnet used for PXE booting. (string
# value)
#network_cidr = 192.0.2.0/24


The install guide (https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Configuring_the_Director.html) says:


network_cidr
The network that the director uses to manage Overcloud instances. This is the Provisioning network. Leave this as the default 192.0.2.0/24 unless you are using a different subnet for the Provisioning network.


Version-Release number of selected component (if applicable):

python-rdomanager-oscplugin-0.0.8-44.el7ost.noarch
Comment 3 Dan Yocum 2015-09-04 11:48:15 EDT
Looks like the documentation needs to be fixed as well.  The doc says this:

discovery_iprange
A range of IP address that the director's discovery service uses during the PXE boot and provisioning process. Use comma-separated values to define the start and end of this range. For example, 192.0.2.100,192.0.2.120. Make sure this range contains enough IP addresses for your nodes and does not conflict with the range for dhcp_start and dhcp_end.

The undercloud.conf.sample file says this (this is correct):

# Temporary IP range that will be given to nodes during the discovery
# process.  Should not overlap with the range defined by dhcp_start
# and dhcp_end, but should be in the same network. (string value)
discovery_iprange = 192.0.2.100,192.0.2.120

Specifically, the word missing in the documentation is "temporary".
Comment 5 Mike Burns 2016-04-07 16:50:54 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 7 Dmitry Tantsur 2016-10-17 05:13:17 EDT
Hi! I don't quite agree with the assumption of this report. The comments in undercloud.conf.sample are NOT documentation, they just give a quick overview of the options. It's pretty natural, that the documentation is more complete and easier to read.

Also, the configuration options are being changes way too often to keep them up with the documentation, to be honest.

Note You need to log in before you can comment on or make changes to this bug.