Bug 1260166 - Unable to log in as admin and unable to reset admin password after 3.6pre->3.6pre upgrade
Unable to log in as admin and unable to reset admin password after 3.6pre->3....
Status: CLOSED DUPLICATE of bug 1260573
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.6.0
Assigned To: Martin Perina
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 11:48 EDT by Neal Gompa
Modified: 2016-02-10 14:34 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 08:21:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Gompa 2015-09-04 11:48:25 EDT
Description of problem:
After upgrading to 3.6pre earlier in the week, I upgraded again and ran engine-setup. Afterward, I was unable to log in using admin@internal user. I tried to run "engine-config -s AdminPassword=interactive", but it doesn't work, saying there's no such entry.

Version-Release number of selected component (if applicable):
3.6.0-0.0.master.20150901142419.git8df944a.el7.centos.noarch

How reproducible:
Always

Steps to Reproduce:
1. Upgrade from 3.5 to 3.6.0-0.0.master.20150819134454.gite6b79a7.el7.centos
2. Upgrade again to 3.6.0-0.0.master.20150901142419.git8df944a.el7.centos.noarch
3. Attempt to log in or set password

Actual results:
Unable to log in, getting message: "Cannot Login. User Password has expired, Please change your password."

"engine-config -s AdminPassword=interactive" returns "Error setting AdminPassword's value. No such entry."

Expected results:
I should be able to log in, and if I wanted to change my password, I should be able to.
Comment 1 Alon Bar-Lev 2015-09-05 13:52:23 EDT
FYI: engine-config is not used to set password any more, use ovirt-engine-extension-aaa-jdbc tool to do that.

not sure why the password expired though, leaving this for martin.
Comment 2 Martin Perina 2015-09-05 16:35:39 EDT
Hi Neal,

could you please attach your setup logs? They are located in /var/log/ovirt-engine/setup.

To fix 'password expired' issue, so you could log in using 'admin@internal', please execute following command:

  ovirt-aaa-jdbc-tool user password-reset admin --password-valid-to="<DATE>"

where <DATE> should be future date in the format "yyyy-MM-dd HH:mm:ssX" (more info can be found at [1]).

Thanks

Martin

[1] http://docs.oracle.com/javase/6/docs/api/java/text/SimpleDateFormat.html
Comment 3 Martin Perina 2015-09-11 08:21:15 EDT
Closing as duplicate, because reproduce steps are the same as in BZ1260573

*** This bug has been marked as a duplicate of bug 1260573 ***

Note You need to log in before you can comment on or make changes to this bug.