Bug 1260202 - Update selinux policies to allow new openvswitch ports
Update selinux policies to allow new openvswitch ports
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-selinux (Show other bugs)
7.0 (Kilo)
All Linux
urgent Severity urgent
: z3
: 7.0 (Kilo)
Assigned To: Ryan Hallisey
yeylon@redhat.com
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 13:56 EDT by Flavio Leitner
Modified: 2016-04-18 03:12 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-selinux-0.6.42-2.el7ost
Doc Type: Bug Fix
Doc Text:
With this update, OpenvSwitch changed from using port 6633 to 6653. SELinux expects OpenvSwitch to use port 6633 causing OVS to fail when running. To fix the issue, you need to tell SELinux that OVS is running on port 6653 instead of 6633.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 12:04:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Leitner 2015-09-04 13:56:16 EDT
Description of problem:

Since 2.4.0, the OVS has changed to use IANA ports so the selinux policies need to be updated. See the upstream commit below:
https://github.com/openvswitch/ovs/commit/d4763d1d4efbbcfd884df2d668980d61ec89d75a

OSP openvswitch is going to be updated to 2.4.0 soon.

fbl
Comment 4 Flavio Leitner 2015-11-09 11:35:16 EST
Ryan,

Is there anything missing here?
Let me know if I can help somehow.

Thanks,
fbl
Comment 5 Ryan Hallisey 2015-11-09 13:38:52 EST
All set. Lost this in a pile of emails.
Comment 7 Lon Hohberger 2015-12-01 10:25:55 EST
Verified: no port issues during automation runs.
Comment 10 errata-xmlrpc 2015-12-21 12:04:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2676

Note You need to log in before you can comment on or make changes to this bug.