Bug 1260252 - Spurious package sssd-common-1.13.0-2.fc22.x86_64 requires libldb(x86-64) = 1.1.20, but none of the providers can be installed message
Spurious package sssd-common-1.13.0-2.fc22.x86_64 requires libldb(x86-64) = 1...
Status: CLOSED DUPLICATE of bug 1148627
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-04 22:10 EDT by Orion Poplawski
Modified: 2015-09-11 06:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-07 08:19:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debugdata.tar (8.13 MB, application/x-tar)
2015-09-04 22:10 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2015-09-04 22:10:20 EDT
Created attachment 1070440 [details]
debugdata.tar

Description of problem:

Currently there is an issue with a kde update.  I'm getting:

# dnf upgrade --best  --debugsolver
Repository rawhide has no mirror or baseurl set.
Repository rawhide-debuginfo has no mirror or baseurl set.
Repository rawhide-source has no mirror or baseurl set.
Last metadata expiration check performed 0:10:56 ago on Fri Sep  4 19:54:17 2015.
Error: nothing provides libKF5Baloo.so.5()(64bit) needed by plasma-desktop-5.4.0-2.fc22.x86_64.
package sddm-breeze-5.4.0-6.fc22.1.noarch requires plasma-workspace = 5.4.0-6.fc22.1, but none of the providers can be installed.
package sssd-common-1.13.0-2.fc22.x86_64 requires libldb(x86-64) = 1.1.20, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

The message about sssd-common though is very strange as they are both already installed:

Installed Packages
libldb.x86_64        1.1.20-1.fc22             @System        
sssd-common.x86_64   1.13.0-2.fc22             @System        

Version-Release number of selected component (if applicable):
libsolv-0.6.11-2.fc22.x86_64
hawkey-0.6.0-1.fc22.x86_64
dnf-1.1.0-2.fc22.noarch
Comment 1 Radek Holy 2015-09-07 08:19:27 EDT

*** This bug has been marked as a duplicate of bug 1148627 ***
Comment 2 Andrew Meredith 2015-09-11 06:27:26 EDT
This is not an issue with the debug output of dnf, this is a packaging problem.

# dnf upgrade
Last metadata expiration check performed 22:08:46 ago on Thu Sep 10 13:14:58 2015.
Dependencies resolved.
======================================================================================================================
 Package                       Arch                    Version                         Repository                Size
======================================================================================================================
Skipping packages with broken dependencies:
 libldb                        x86_64                  1.1.21-1.fc22                   updates                  133 k
 libldb-devel                  x86_64                  1.1.21-1.fc22                   updates                   76 k

Transaction Summary
======================================================================================================================

Nothing to do.
Complete!


Having downloaded the packages...


# rpm -Uvh libldb-1.1.21-1.fc22.x86_64.rpm libldb-devel-1.1.21-1.fc22.x86_64.rpm 
error: Failed dependencies:
	libldb(x86-64) = 1.1.20 is needed by (installed) sssd-common-1.13.0-2.fc22.x86_64


It would seem that the current version of sssd-common is pinned to the 1.1.20 version of libldb, preventing its upgrade to 1.1.21

This is a packaging issue not an issue with debug output, so therefore is not a duplicate of bug 1148627

Note You need to log in before you can comment on or make changes to this bug.