Bug 1260272 - SELinux is preventing named from 'read' accesses on the file ip_local_port_range.
SELinux is preventing named from 'read' accesses on the file ip_local_port_ra...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
24
x86_64 Unspecified
high Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8f0c6c06d7b5a69d9531dcd1e31...
:
: 1260273 1260274 1260275 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-05 08:35 EDT by Nicolas Mailhot
Modified: 2016-03-23 12:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-147.fc24 selinux-policy-3.13.1-179.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 12:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2015-09-05 08:35:39 EDT
Description of problem:
SELinux is preventing named from 'read' accesses on the file ip_local_port_range.

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que named devrait être autorisé à accéder read sur ip_local_port_range file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep named /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:named_t:s0
Target Context                system_u:object_r:sysctl_net_t:s0
Target Objects                ip_local_port_range [ file ]
Source                        named
Source Path                   named
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-146.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.3.0-0.rc0.git7.1.fc24.x86_64 #1
                              SMP Fri Sep 4 14:36:30 UTC 2015 x86_64 x86_64
Alert Count                   6
First Seen                    2015-09-05 14:09:06 CEST
Last Seen                     2015-09-05 14:33:32 CEST
Local ID                      efd2f72d-80b9-4f24-9191-173ab77f7bbc

Raw Audit Messages
type=AVC msg=audit(1441456412.169:790): avc:  denied  { read } for  pid=1592 comm="named" name="ip_local_port_range" dev="proc" ino=29564 scontext=system_u:system_r:named_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=file permissive=1


Hash: named,named_t,sysctl_net_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-146.fc24.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.3.0-0.rc0.git7.1.fc24.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-09-11 08:09:54 EDT
*** Bug 1260273 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2015-09-11 08:09:57 EDT
*** Bug 1260274 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2015-09-11 08:10:02 EDT
*** Bug 1260275 has been marked as a duplicate of this bug. ***
Comment 5 Jan Kurik 2016-02-24 10:47:52 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Fedora Update System 2016-03-11 04:56:01 EST
selinux-policy-3.13.1-178.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1350c96015
Comment 7 Fedora Update System 2016-03-11 14:25:44 EST
selinux-policy-3.13.1-178.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1350c96015
Comment 8 Fedora Update System 2016-03-16 09:41:51 EDT
selinux-policy-3.13.1-179.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8f142bb969
Comment 9 Fedora Update System 2016-03-18 10:58:36 EDT
selinux-policy-3.13.1-179.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8f142bb969
Comment 10 Fedora Update System 2016-03-23 12:54:39 EDT
selinux-policy-3.13.1-179.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.