Bug 1260276 - SELinux is preventing systemd-logind from 'open' accesses on the file /sys/firmware/efi/efivars/OsIndicationsSupported-8be4df61-93ca-11d2-aa0d-00e098032b8c.
SELinux is preventing systemd-logind from 'open' accesses on the file /sys/fi...
Status: CLOSED DUPLICATE of bug 1244973
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:521959e7b316cfce4ad05071226...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-05 08:37 EDT by Nicolas Mailhot
Modified: 2015-09-11 08:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 08:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2015-09-05 08:37:15 EDT
Description of problem:
SELinux is preventing systemd-logind from 'open' accesses on the file /sys/firmware/efi/efivars/OsIndicationsSupported-8be4df61-93ca-11d2-aa0d-00e098032b8c.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If vous souhaitez corriger l'étiquette. 
L'étiquette par défaut de /sys/firmware/efi/efivars/OsIndicationsSupported-8be4df61-93ca-11d2-aa0d-00e098032b8c devrait être sysfs_t.
Then vous pouvez exécuter restorecon.
Do
# /sbin/restorecon -v /sys/firmware/efi/efivars/OsIndicationsSupported-8be4df61-93ca-11d2-aa0d-00e098032b8c

*****  Plugin catchall (1.49 confidence) suggests   **************************

If vous pensez que systemd-logind devrait être autorisé à accéder open sur OsIndicationsSupported-8be4df61-93ca-11d2-aa0d-00e098032b8c file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep systemd-logind /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_logind_t:s0
Target Context                system_u:object_r:efivarfs_t:s0
Target Objects                /sys/firmware/efi/efivars/OsIndicationsSupported-
                              8be4df61-93ca-11d2-aa0d-00e098032b8c [ file ]
Source                        systemd-logind
Source Path                   systemd-logind
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-146.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.3.0-0.rc0.git7.1.fc24.x86_64 #1
                              SMP Fri Sep 4 14:36:30 UTC 2015 x86_64 x86_64
Alert Count                   5
First Seen                    2015-09-05 14:29:34 CEST
Last Seen                     2015-09-05 14:29:43 CEST
Local ID                      c2bdb390-74ea-4b4c-9bdd-a6cd2e9bb30b

Raw Audit Messages
type=AVC msg=audit(1441456183.671:652): avc:  denied  { open } for  pid=987 comm="systemd-logind" path="/sys/firmware/efi/efivars/OsIndicationsSupported-8be4df61-93ca-11d2-aa0d-00e098032b8c" dev="efivarfs" ino=11360 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:efivarfs_t:s0 tclass=file permissive=1


Hash: systemd-logind,systemd_logind_t,efivarfs_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-146.fc24.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.3.0-0.rc0.git7.1.fc24.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-09-11 08:20:49 EDT

*** This bug has been marked as a duplicate of bug 1244973 ***

Note You need to log in before you can comment on or make changes to this bug.