This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1260279 - DNF does not include a download-only option
DNF does not include a download-only option
Status: CLOSED DUPLICATE of bug 1048433
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-05 08:46 EDT by Jason H.
Modified: 2015-09-07 05:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: DNF should have --downloadonly option, like yum Reason: yum has a -w or --downloadonly option to download any packages to be installed or updated. DNF does have a download command, they are different. The command "yum --downloadonly update" will download and stage all updates to their proper directories in /var/cache, while "dnf download" behaves more like "yumdownloader", which puts all downloads into the current directory, reguardless of repository. I use the "yum --downloadonly" command frequently to download updates while the computer is in use, then apply them when the computer is shutting down or restarting (via custom SystemD script). Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-07 05:14:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason H. 2015-09-05 08:46:56 EDT
Description of problem: yum has a -w or --downloadonly option to download any packages to be installed or updated.  DNF does have a download command, they are different.  The command "yum --downloadonly update" will download and stage all updates to their proper directories in /var/cache, while "dnf download" behaves more like "yumdownloader", which puts all downloads into the current directory, reguardless of repository.

I use the "yum --downloadonly" command frequently to download updates while the computer is in use, then apply them when the computer is shutting down or restarting (via custom SystemD script).

Version-Release number of selected component (if applicable): dnf-1.1.0-2.fc22.noarch


How reproducible: Always


Steps to Reproduce:
1. Run "dnf --downloadonly update"
2.
3.

Actual results:
No match for argument: --downloadonly

Expected results:
DNF will download packages to cache.

Additional info:
Comment 1 Radek Holy 2015-09-07 05:14:08 EDT
Hello, this is a duplicate.

You might be also interested in using dnf-automatic configured to download the updates (https://bugzilla.redhat.com/show_bug.cgi?id=1048433#c14).

*** This bug has been marked as a duplicate of bug 1048433 ***

Note You need to log in before you can comment on or make changes to this bug.