Bug 1260281 - [Radeon/Tonga] missing xf86-video-amdgpu package
[Radeon/Tonga] missing xf86-video-amdgpu package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-05 09:44 EDT by Edward O'Callaghan
Modified: 2015-11-16 13:25 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 15:29:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward O'Callaghan 2015-09-05 09:44:30 EDT
Description of problem:

It maybe necessary for the new xf86-video-amdgpu to be package up to properly support CI type hw on all possible configurations of Fedora 23. Perhaps it is prudent to package it up and make it available.
Comment 1 elijah.snyder1 2015-11-09 12:37:33 EST
Radeon users with Tonga and newer cards are currently in limbo.

We can't build Catalyst for Fedora 23 because the gcc 5 compiled Catalyst simply doesn't load.

The amdgpu Xorg driver is not shipped with Fedora 23.

The radeon Xorg driver does not support Tonga and newer.

Any updates?


Please escalate this ticket's severity to at least Medium.
Comment 2 Dave Airlie 2015-11-09 15:29:54 EST
xorg-x11-drv-modesetting should be fine as the driver.
Comment 3 elijah.snyder1 2015-11-09 16:30:40 EST
modesetting provides only software rendering.


The amdgpu stack is incomplete without the Xorg driver.
Comment 4 Dave Airlie 2015-11-10 06:12:39 EST
modesetting provides hw support on this card.
Comment 5 elijah.snyder1 2015-11-10 16:46:04 EST
Maybe it's just me, then.


modesetting falls back to software rendering on my system with several "Invalid ROM Contents" errors.  ASUS Radeon R9 380 4G "Strix Gaming" edition.


amdgpu works fresh out of a build.  Why not include an amdgpu driver?
Comment 6 Dave Airlie 2015-11-10 19:27:27 EST
because modesetting is exactly the same, and there is no need to support both.

I'm not sure where Invalid ROM contents could be coming from, where do you see it.

Maybe you are mixing up amdgpu the kernel driver with amdgpu the userspace driver. Either way it should work out of the box as-is.

Maybe file another bug with dmesg and Xorg log files.
Comment 7 elijah.snyder1 2015-11-10 22:10:45 EST
I'm not confusing the amdgpu kernel driver with the xorg driver.  That is a kernel message from the amdgpu kernel driver included for posterity.

Here are snippets from the log for AIGLX, GL and DRI2/3.

modesetting driver:
[ 83456.164] (II) AIGLX: Screen 0 is not DRI2 capable
[ 83456.164] (EE) AIGLX: reverting to software rendering
[ 83456.165] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 83456.166] (II) AIGLX: Loaded and initialized swrast

[ 83456.166] (II) GLX: Initialized DRISWRAST GL provider for screen 0

[ 83456.160] (EE) modeset(0): [DRI2] No driver mapping found for PCI device 0x1002 / 0x6939
[ 83456.160] (EE) modeset(0): Failed to initialize the DRI2 extension.


amdgpu driver:
[ 83644.222] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 83644.222] (II) AIGLX: enabled GLX_ARB_create_context
[ 83644.222] (II) AIGLX: enabled GLX_ARB_create_context_profile
[ 83644.222] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[ 83644.222] (II) AIGLX: enabled GLX_INTEL_swap_event
[ 83644.222] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[ 83644.222] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[ 83644.222] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[ 83644.222] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[ 83644.222] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[ 83644.223] (II) AIGLX: Loaded and initialized radeonsi

[ 83644.223] (II) GLX: Initialized DRI2 GL provider for screen 0

[ 83644.173] (II) AMDGPU(0): [DRI2] Setup complete
[ 83644.173] (II) AMDGPU(0): [DRI2]   DRI driver: radeonsi
[ 83644.173] (II) AMDGPU(0): [DRI2]   VDPAU driver: radeonsi

[ 83644.173] (**) AMDGPU(0): DRI3 enabled


These results are significantly different.
Comment 8 elijah.snyder1 2015-11-16 11:58:24 EST
Any tips for the modesetting driver or should I open another bug?
Comment 9 Jérôme Glisse 2015-11-16 13:18:38 EST
Missing PCIID
Comment 10 elijah.snyder1 2015-11-16 13:25:34 EST
Ah.  Could be my card is missing from the kernel amdgpu module and that's why I end up in bad shape with the modesetting driver?

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Tonga PRO [Radeon R9 285/380] [1002:6939] (rev f1)

Note You need to log in before you can comment on or make changes to this bug.