Bug 1260296 - Can not open file : /proc/net/dev
Can not open file : /proc/net/dev
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xosview (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Terje Røsten
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-05 13:57 EDT by George R. Goffe
Modified: 2016-07-19 15:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 15:18:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George R. Goffe 2015-09-05 13:57:05 EDT
Description of problem:
after some hours of "normal" operation, xosview terminates with this message.

Version-Release number of selected component (if applicable):
xosview-1.16-4.fc22.x86_64

How reproducible:
always

Steps to Reproduce:
1./usr/bin/xosview +cpus -int -geometry 0395x0968+1124+0000
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Terje Røsten 2015-10-04 09:53:14 EDT
Update available here:

 https://bodhi.fedoraproject.org/updates/FEDORA-2015-26ac21b729

Does xosview 1.17 improve things for you?

Still issue with this bug and 
 https://bugzilla.redhat.com/show_bug.cgi?id=1212671 ?
Comment 2 Terje Røsten 2015-10-21 16:22:51 EDT
Hi George, had time to check the new 1.17 release?
Comment 3 George R. Goffe 2015-10-22 13:59:21 EDT
Terje,

I have not checked your fix. How do I go about getting the fix?

My current xosview is xosview-1.17-1.fc22.x86_64. If this version has the fix, I'll test it and report back here. Ok?

Thanks,

George...
Comment 4 Terje Røsten 2015-11-01 09:39:11 EST
Yes, 1.17 might have fixed the issue, while 1.16 was the previous version.

Any improvements seen in current 1.17 version?
Comment 5 George R. Goffe 2015-11-02 13:19:41 EST
Terje,

I'll test it today and report back here

George...
Comment 6 George R. Goffe 2015-11-03 16:34:31 EST
Terge,

I have been running in the same configuration that caused failures before but have not seen the failure. I'd say go ahead and close this one.

Thanks for your hard work!

George...
Comment 7 Terje Røsten 2015-11-03 17:14:01 EST
Thanks for your report!
Comment 8 George R. Goffe 2015-11-04 09:45:17 EST
Terje,

Sorry to do this to you but one of the two xosview processes is now gone from my system but there's no message. Sigh... I have restarted both and will post the results of this in 24+ hours.

Regards,

George...
Comment 9 George R. Goffe 2015-11-04 22:20:10 EST
Terje,

Can you give me some pointers on how to debug this code please? I have tried "gdb -p <pid>" but when I type in "run" gdb wants to start a new instance. strace doesn't want to work well either but would generate HUGE amounts of data over a 24 hour period.

I started "runxosview" just a few hours ago and have already experienced a failure. I did this from a "Konsole" but that ended too.

The runxosview script has two lines with "xosview +cpus -int - geometry..." in it separated by "sleep 3".

Your thoughts would be helpful.

Thanks,

George...
Comment 10 George R. Goffe 2015-11-07 02:15:11 EST
Terje,

With the last failure, the message now reads "Can not open /dev/net/wireless".

George...
Comment 11 Terje Røsten 2015-11-07 08:39:17 EST
Thanks,

I would guess the reason this shows up is lack of file descriptors, something in xosview is leaking fds.

Can you use e.g. lsof to verify this?
Comment 12 George R. Goffe 2015-11-08 00:13:58 EST
Terje,

I tried running xosview with another konsole running a sleep 30;lsof | grep xosview script running. NOTHING significant... file descriptors went from 52 to 28....

I'm gonna reboot this system after installing maintenance and a newer kernel and will retry gdb... I'll let you know. Maybe my gdb problems are a bug that needs to be reported. Sigh...

George...
Comment 13 Fedora End Of Life 2016-07-19 15:18:07 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.