Bug 1260299 - dnf removing important packages like zlib and sqlite within removal of some packages
dnf removing important packages like zlib and sqlite within removal of some p...
Status: CLOSED DUPLICATE of bug 1222812
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-05 15:09 EDT by Roni Laukkarinen
Modified: 2015-09-07 08:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-07 08:38:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roni Laukkarinen 2015-09-05 15:09:48 EDT
Description of problem:

I have had this problem twice now. It seems that when removing some packages with dnf, it automatically removes packages important to system like zlib and sqlite. I'm newcomer to Fedora, but had centos before it and suse before that so I'm quite at home with rpm-redhat-based systems.


Version-Release number of selected component (if applicable):

Fedora Server, 22.

How reproducible:

Very.

Steps to Reproduce:
1. Install skype or postgresql via dnf or rpm
2. Run `dnf remove skype` or `dnf remove postgresql`, hit Y
3. Have a broken system

Actual results:

Since most of the important packages and commands depend on zlib, wget, curl, dnf, rpm or connecting with ssh no longer work.

Expected results:

Broken system.

Additional info:

Got it resolved with the tips and kind help of #fedora at freenode and my own findings. Tips to solve: have a VM or another machine with rpm2cpio, get the files from koji.fedoraproject.org/koji, unpack them and copy them over to the system, then `dnf reinstall zlib uuid sqlite`.

Dnf should not remove zlib only during removal of postgresql or freaking skype... this could be happening for many dnf remove commands if the user is not careful enough.
Comment 1 Roni Laukkarinen 2015-09-05 15:15:48 EDT
Here are the pastebins, by the way:
http://pastebin.com/hW0BfEi1
http://pastebin.com/LW4TKSc3
Comment 2 Radek Holy 2015-09-07 08:38:51 EDT
Looks like a duplicate of the bug 1222812.

*** This bug has been marked as a duplicate of bug 1222812 ***

Note You need to log in before you can comment on or make changes to this bug.