Bug 1260307 - The XSLT stylesheet ‘/usr/share/yelp/xslt/db2html.xsl’ is either missing or not valid.
The XSLT stylesheet ‘/usr/share/yelp/xslt/db2html.xsl’ is either missing or n...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yelp-xsl (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-05 16:49 EDT by kakoskin
Modified: 2015-10-29 08:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 08:43:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kakoskin 2015-09-05 16:49:50 EDT
Description of problem:
When opening help for gParted I get only following error:

Unknown Error

The XSLT stylesheet ‘/usr/share/yelp/xslt/db2html.xsl’ is either missing or not valid.

Version-Release number of selected component (if applicable):
>yelp.x86_64                        1:3.17.91-1.fc23        
yelp-libs.x86_64                   1:3.17.91-1.fc23        
yelp-xsl.noarch                    3.17.90-1.fc23  
gparted.x86_64                       0.23.0-1.fc23

How reproducible:
Always

Steps to Reproduce:
1.Open gparted.
2.Open help.

Alternatively:
1. Run Yelp from commandline
2. Choose "All help"
3. Navigate to gParted manual. Also GPL and LGPL give same error. 

Actual results:
Window with above mentioned error.

Expected results:
Correctly displayed help page.

Additional info:
This happens on Cinnamon desktop.
Comment 1 Joachim Frieben 2015-09-10 01:26:57 EDT
The same error occurs when the help for totem ("Videos") is opened.
Comment 2 kakoskin 2015-09-10 11:30:34 EDT
Sorry. It seems that I forgot to mention that file in question exists and is readable as an ordinary user.
Comment 3 Giulio 'juliuxpigface' 2015-10-29 08:43:01 EDT
I'm closing this since I can't reproduce the bug with the version "3.18.1-1.fc23" of yelp, yelp-xsl and yelp-libs.

Feel free to reopen it if you keep encountering this issue.

Note You need to log in before you can comment on or make changes to this bug.