Bug 1260319 - Fedup from 22 to 23-Beta-TC1 does not boot
Fedup from 22 to 23-Beta-TC1 does not boot
Status: CLOSED DUPLICATE of bug 1245838
Product: Fedora
Classification: Fedora
Component: fedup-dracut (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-05 19:58 EDT by Robert Roth
Modified: 2015-09-08 11:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 11:07:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Roth 2015-09-05 19:58:55 EDT
Description of problem:

After trying to fedup from 22 to 23-Beta-TC1 on x86_64 the boot is broken.

Version-Release number of selected component (if applicable):
Computer does not boot, can't check fedup version, but the computer had all updates installed on 5th of September.

How reproducible:
I haven't tried multiple times, breaking the boot once was enough

Steps to Reproduce:
1. Execute fedup --network 23 --instrepo http://dl.fedoraproject.org/pub/alt/stage/23_Beta_TC1
2. After the upgrade is prepared, reboot


Actual results:
 Computer does not boot

Expected results:
 Fedora is updated

Additional info:
I see the following kernel log instead of booting (not very verbose):
systemd[1]: [/etc/systemd/system/system-upgrade-shell.service:8] Couldn't unescape assignment, ignoring: TERM=linux PS1=system-upgrade:\w\$\x20
systemd[1]: Caught <ABRT>, dumped core as pid 194
systemd[1]: Freezing execution
Comment 1 Will Woods 2015-09-08 11:07:07 EDT
fedup is broken and unfixable; it's been deprecated and is being replaced with the `dnf system-upgrade` plugin. This is mentioned on the Common Bugs page:

  https://fedoraproject.org/wiki/Common_F23_bugs#fedup-systemd-crash

See https://fedoraproject.org//wiki/Changes/DNF_System_Upgrades for details on the replacement.

*** This bug has been marked as a duplicate of bug 1245838 ***

Note You need to log in before you can comment on or make changes to this bug.