Bug 1260346 - wireless internet hardware not detected after updating kernel-core without kernel-modules
wireless internet hardware not detected after updating kernel-core without ke...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 01:59 EDT by Peter H. Jones
Modified: 2015-09-15 11:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 11:36:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of failing kernel (69.76 KB, text/plain)
2015-09-06 01:59 EDT, Peter H. Jones
no flags Details
dmesg of previous kernel that works (80.15 KB, text/plain)
2015-09-06 02:01 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2015-09-06 01:59:57 EDT
Created attachment 1070629 [details]
dmesg of failing kernel

Description of problem:
Wireless internet hardware not detected on a Fujitsu Lifebok

Version-Release number of selected component (if applicable):
kernel-core-4.1.6-201.fc22.x86_64.

How reproducible:
Every time

Steps to Reproduce:
1.Boot
2.Configure wifi

Actual results:
No wifi hardware visible

Expected results:
Wifi should be visible

Additional info:
kernel-core-4.1.6-200.fc22.x86_64 works fine
Comment 1 Peter H. Jones 2015-09-06 02:01:01 EDT
Created attachment 1070630 [details]
dmesg of previous kernel that works
Comment 2 Peter H. Jones 2015-09-07 06:13:15 EDT
Works with
kernel-headers-4.1.6-201.fc22.x86_64
kernel-core-4.1.6-201.fc22.x86_64
aernel-modules-4.1.6-201.fc22.x86_64
Comment 3 Peter H. Jones 2015-09-15 11:20:14 EDT
I was able to reproduce the behaviour by installing only
kernel-core-4.1.7-200.fc22.x86_64 without the corresponing kernel-modules rpm. Dnf allowed me to do that without complaining about missing dependencies. After I installed only kernel-core, I found:
The system would not power off from the screen menu. When I tried a poweroff command as root, I got an error message and no power-down.init 0 gave the usual warning to all consoles, but nothing further happened. After powering-down manually and restarting in kernel-4.1.7, there was no wifi menu available.

I shut down and restarted in kernel-4.1.6. I removed 4.1.7 and tried to install only kernel-modules-4.1.7. I got a dependency message. When I installed both kernel-core-4.1.7 and kernel-modules-4.1.7 and restarted in kernel-4.1.7, the system works fine.

There are two possible bugs here:
1) Failure to power down when only a new kernel-core is installed
2) Ability to install and run only a different kernel-core. Seeing the great degradation of the system, I would have liked a warning when I did that.
Comment 4 Josh Boyer 2015-09-15 11:36:11 EDT
The ability to install only kernel-core is intentional.  That is how our cloud products install a minimal kernel image.

For normal machines, such as a desktop or laptop, the default install has 3 packages:

kernel
kernel-core
kernel-modules

The kernel package requires both kernel-core and kernel-modules.  If your machine is lacking the kernel package, you likely removed it at some point.  There is still no bug here.

Note You need to log in before you can comment on or make changes to this bug.