Bug 1260354 - [fork][origin_userinterface_526]Could not get all pods info on overview page even click the "and xx more"
[fork][origin_userinterface_526]Could not get all pods info on overview page ...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Jessica Forrester
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 03:14 EDT by yapei
Modified: 2015-09-08 11:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 11:02:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yapei 2015-09-06 03:14:34 EDT
Description of problem:
When we have more than 3 PODs with same status, they will be in collapsing view on overview page.Take 9 pods in same status as an example,when clicking on the collapsing figure only 3 of them are directly shown below, besides, there is one sentence saying '... and 6 more' and a button 'Collapse' to collapse all pods.When clicking on the sentence to get info about remaining 6 pods, nothing appeared

Version-Release number of selected component (if applicable):
oc v1.0.5-194-g2eeec6e
kubernetes v1.1.0-alpha.0-1605-g44c91b1
fork_ami_openshift3_userinterface_public_526_87

How reproducible:
Always

Steps to Reproduce:
1.Create a template
$ https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-stibuild.json
2.Create a ruby app using templates on web
3.Scale up the replicationcontroller 'frontend' 
$ oc scale --replicas=9 replicationcontrollers frontend-1
4.Check pods status and info on overview page

Actual results:
step4:
only 3 pods info is displayed, can't get info about remaining 6 pods 

Expected results:
step4:
we should get all pods status info on overview page

Additional info:
Comment 1 Jessica Forrester 2015-09-08 11:02:35 EDT
This was intentional in the new design, since typically pods are failing for the same reason, stuck in pending for the same reason, or they are just running.  A link was added to go see all of the pods for the deployment.

Note You need to log in before you can comment on or make changes to this bug.